summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnes Hecan2020-09-09 17:32:23 +0200
committerEnes Hecan2020-09-09 17:32:23 +0200
commit68ce1054b6e6b5e2dd6d3b1c4ca3e322ba9c0023 (patch)
tree9aa9a608ab60fb96b6d4981de2b18dd77ef981e7
parent7b27bb1b7cb01ae94f9326e7de3cb0e71f4514bc (diff)
downloadaur-68ce1054b6e6b5e2dd6d3b1c4ca3e322ba9c0023.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD48
3 files changed, 33 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd1a69dbbc85..d596798ce620 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,20 @@ pkgbase = whatsapp-for-linux
pkgrel = 1
url = https://github.com/eneshecan/whatsapp-for-linux
arch = x86_64
+ arch = aarch64
license = GPL
- makedepends = cmake
+ makedepends = git
depends = gtkmm3
depends = webkit2gtk
+ depends = nuspell
+ depends = hspell
+ depends = libvoikko
+ depends = aspell
+ depends = gst-plugins-base
provides = whatsapp-for-linux
- source = whatsapp-for-linux-1.0.8.tar.gz::https://github.com/eneshecan/whatsapp-for-linux/archive/v1.0.8.tar.gz
- sha1sums = 3f12c2909b1d60cc1c247e29f9f4b834c18c7494
+ conflicts = whatsapp-for-linux
+ source = git+https://github.com/eneshecan/whatsapp-for-linux
+ sha256sums = SKIP
pkgname = whatsapp-for-linux
diff --git a/.gitignore b/.gitignore
index 8d78c8370330..4e9fccdf486e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/
src/
*.tar*
+.idea
diff --git a/PKGBUILD b/PKGBUILD
index f3310af7cc28..56fe821b9a27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,32 @@
-# Maintainer: Caio Novais <caionov08 at gmail dot com>
-# shellcheck shell=bash
-# shellcheck disable=SC2034,SC2154
+# Maintainer: Enes Hecan <nshecan@gmail.com>
+
pkgname=whatsapp-for-linux
pkgver=1.0.8
pkgrel=1
pkgdesc="An unofficial WhatsApp linux client desktop application."
-arch=('x86_64')
-url="https://github.com/eneshecan/$pkgname"
-license=('GPL')
-depends=('gtkmm3' 'webkit2gtk')
-makedepends=('cmake')
-provides=("$pkgname")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/eneshecan/$pkgname/archive/v$pkgver.tar.gz")
-sha1sums=('3f12c2909b1d60cc1c247e29f9f4b834c18c7494')
+url="https://github.com/eneshecan/whatsapp-for-linux"
+arch=(x86_64 aarch64)
+license=(GPL)
+depends=(gtkmm3 webkit2gtk nuspell hspell libvoikko aspell gst-plugins-base)
+makedepends=(git cmake)
+provides=(whatsapp-for-linux)
+conflicts=(whatsapp-for-linux)
+source=("git+https://github.com/eneshecan/whatsapp-for-linux")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ cmake . > /dev/null
+ cat "src/VERSION"
+}
build() {
- cd "$srcdir/$pkgname-$pkgver" || exit
- mkdir -p build/release && cd build/release || exit
- cmake -DCMAKE_BUILD_TYPE=Release ../..
- make
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
- msg2 "Copying binary..."
- install -Dm755 "$srcdir/$pkgname-$pkgver/build/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
-
- msg2 "Copying resources..."
- # .desktop
- install -Dm644 "$srcdir/$pkgname-$pkgver/resource/desktop/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- # Icons
- for i in 16x16 32x32 64x64 128x128 256x256; do
- install -Dm644 "$srcdir/$pkgname-$pkgver/resource/image/icons/hicolor/$i/apps/$pkgname.png" "$pkgdir/usr/share/icons/hicolor/$i/apps/$pkgname.png"
- done
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
}