aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco GuimarĂ£es2020-01-20 12:30:41 -0300
committerFrancisco GuimarĂ£es2020-01-20 12:30:41 -0300
commit16e90631441c9c0e4aedfdca0abeb7e98a115f78 (patch)
tree4ecbb2b707d8b44ebd1461084cfb51ad7a69906a
parentdaf332233b644c2278f9f656ad4771f62c640e48 (diff)
downloadaur-16e90631441c9c0e4aedfdca0abeb7e98a115f78.tar.gz
Update user script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--whatsapp-nativefier-dark-inject.js66
3 files changed, 39 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c292be23be50..2b28d67d1235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = whatsapp-nativefier-dark
pkgdesc = WhatsApp desktop built with nativefier (electron) using dark theme
- pkgver = 0.2.0000
+ pkgver = 0.20200116224810
pkgrel = 1
url = https://web.whatsapp.com
arch = armv7l
@@ -18,7 +18,7 @@ pkgbase = whatsapp-nativefier-dark
source = whatsapp-nativefier-dark-inject.js
sha256sums = 3899581abcfed9b40b7208bbbca8bdbfe3ae9655980dbf55f04dec9cb3309f27
sha256sums = 61f0033b6ac363699620065b18d54b922bc597c243667adafa61f8545839e0ad
- sha256sums = 8c6e6f8ed0ad4a1cfe2b7d26565cbeb8cf00b7af5bb063213a1aa7938d925ec9
+ sha256sums = ed4727b01f02f6b65285e27a12c239dbc2df42a51f68de7400524d080ba14f10
pkgname = whatsapp-nativefier-dark
diff --git a/PKGBUILD b/PKGBUILD
index 39d0e85a5ad9..b99ac2cddcc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Francisco Guimaraes <francisco at gmail dot com>
pkgname=whatsapp-nativefier-dark
-pkgver=0.2.0000
+pkgver=0.20200116224810
pkgrel=1
pkgdesc="WhatsApp desktop built with nativefier (electron) using dark theme"
arch=("armv7l" "i686" "x86_64")
@@ -17,7 +17,7 @@ source=(
sha256sums=(
"3899581abcfed9b40b7208bbbca8bdbfe3ae9655980dbf55f04dec9cb3309f27"
"61f0033b6ac363699620065b18d54b922bc597c243667adafa61f8545839e0ad"
- "8c6e6f8ed0ad4a1cfe2b7d26565cbeb8cf00b7af5bb063213a1aa7938d925ec9"
+ "ed4727b01f02f6b65285e27a12c239dbc2df42a51f68de7400524d080ba14f10"
)
build() {
diff --git a/whatsapp-nativefier-dark-inject.js b/whatsapp-nativefier-dark-inject.js
index fc07a128c74b..6b182dda21c4 100644
--- a/whatsapp-nativefier-dark-inject.js
+++ b/whatsapp-nativefier-dark-inject.js
@@ -9,12 +9,12 @@
// @include http://*.web.whatsapp.com/*
// @include https://*.web.whatsapp.com/*
// @run-at document-start
-// @version 0.20191118231148
+// @version 0.20200116224810
// ==/UserScript==
(function() {var css = [
"/**",
" * Everything you need to know is below:",
- " * Source: https://github.com/vednoc/onyx",
+ " * Source: https://github.com/vednoc/dark-whatsapp",
" * Discord: https://discord.gg/NpT8PzA",
" * License: MIT",
" */",
@@ -34,9 +34,9 @@
" --image: url(https://media.discordapp.net/attachments/310799529161129984/417408747812552715/zilesanamin.jpg);",
" --emojiOpacity: 0.75;",
" --ui-font: \'font_name\', \'Segoe UI\', \'Helvetica Neue\', \'Helvetica\', \'Lucida Grande\', \'Arial\', \'Ubuntu\', \'Cantarell\', \'Fira Sans\', sans-serif;",
- " --version: \"WhatsApp by Mew v1.6.2\";",
- " --message: \"Updated on 18th of November. Addressing GH issues and pull requests. \";",
- " --changes: \"See the changelog at: https://github.com/vednoc/onyx/releases\";",
+ " --version: \"WhatsApp by Mew v1.7.1\";",
+ " --message: \"Updated on 16th of January. Ported some fixes to v1. Please switch to v2 because v1 is unsupported! Also, please report issues on GitHub because I can\'t log into USo forums. \";",
+ " --changes: \"Visit https://github.com/vednoc/dark-whatsapp for more info.\";",
" }",
"",
" /* Body reset. */",
@@ -118,33 +118,35 @@
"",
"",
" /* Landing page. */",
- " .app .iFKgT {",
+ " .app ._1qNwV {",
" border: none;",
" background-color: var(--dark) !important; }",
" /* Image. */",
- " .app .iFKgT [data-asset-intro-image] {",
+ " .app ._1qNwV [data-asset-intro-image] {",
" max-width: 200px;",
" max-height: 200px;",
" border-radius: 50%;",
" filter: opacity(0.75);",
" transition: opacity 1s ease !important; }",
" /* Text color. */",
- " .app .iFKgT * {",
+ " .app ._1qNwV * {",
" color: var(--light); }",
" /* Accent bar. */",
- " .app .iFKgT::after {",
+ " .app ._1qNwV::after {",
" border-top-color: var(--accent) !important; }",
" /* Hide the text. */",
- " .iFKgT ._3mkas { font-size: 0px; }",
+ " ._1qNwV .tzihe { font-size: 0px; }",
" /** Theme note. */",
- " .app .iFKgT ._3mkas::before {",
+ " .app ._1qNwV .tzihe::before {",
" display: block;",
" margin-bottom: -20px;",
- " font-size: 16px;",
+ " line-height: 1.3;",
+ " font-size: 20px;",
+ " color: var(--accent);",
" content: var(--message) var(--changes) !important;",
" }",
" /** Theme info. */",
- " .app .iFKgT ._3mkas::after {",
+ " .app ._1qNwV .tzihe::after {",
" display: block;",
" margin-top: 10px;",
" padding-top: 10px;",
@@ -176,10 +178,9 @@
" color: var(--lighter); }",
"",
" /* Global -> Search. */",
- " ._2HS9r {",
- " border-bottom: 0px solid var(--dark);",
- " background-color: var(--darker) !important;",
- " background-color: transparent !important; }",
+ " ._2vikl {",
+ " border-bottom: 1px solid var(--darker);",
+ " background-color: var(--darker) !important; }",
" /* Label background. */",
" .ZP8RM label, .ZP8RM._19OGD {",
" border: 0px solid var(--dark);",
@@ -192,7 +193,7 @@
" .ZP8RM::after,",
" .ZP8RM > div::after {",
" border-color: var(--darker) !important;",
- " background-color: var(--dark) !important; }",
+ " background-color: var(--darker) !important; }",
"",
" /* New group and group info buttons. */",
" ._1w-mX, ._70TS5, ._11p3Q, .r7sRK, ._8-yzK {",
@@ -242,10 +243,10 @@
"",
"",
" /* Settings. */",
- " ._11GZy, ._1KDYa {",
+ " ._7YAGC, ._1KDYa {",
" background-color: var(--darker) !important; }",
" /* Header color. */",
- " ._11GZy header, ._1KDYa header {",
+ " ._7YAGC header, ._1KDYa header {",
" min-height: 50px;",
" height: auto;",
" background-color: var(--darker) !important; }",
@@ -257,25 +258,25 @@
" ._21bWq, ._22oFl {",
" background-color: var(--accent) !important; }",
" /* Reset header height. */",
- " ._11GZy header > div:first-child {",
+ " ._7YAGC header > div:first-child {",
" padding: 12px 0 !important;",
" height: auto; }",
" /* Reset header title in left/right drawers. */",
- " ._11GZy ._1xGbt {",
+ " ._7YAGC ._1xGbt {",
" margin-top: 2px !important;",
" font-size: 16px; }",
" /* Transparent sections. */",
- " ._11GZy ._1CRb5, ._1KDYa ._2LSbZ {",
+ " ._7YAGC ._1CRb5, ._1KDYa ._2LSbZ, ._26JG5 {",
" box-shadow: none !important;",
" background-color: transparent !important; }",
" /* Highlighted sections. */",
- " ._11GZy ._3hhmj ._1CkkN {",
+ " ._7YAGC ._3hhmj ._1CkkN {",
" background-color: var(--darker) !important; }",
" /* Change profile picture. */",
- " ._11GZy .WX_XW, ._11GZy ._2Lbqu, ._1JS2G {",
+ " ._7YAGC .WX_XW, ._7YAGC ._2Lbqu, ._1JS2G {",
" background-color: rgba(0,0,0,0.5) !important; }",
" /* Text color. */",
- " ._11GZy * {",
+ " ._3wYPn * {",
" color: var(--light); }",
" /* Input element. */",
" ._5UNoc ._3hnO5 { border-color: var(--accent) !important; }",
@@ -555,7 +556,7 @@
" color: var(--light) !important; }",
"",
" /* Media/docs/links section. */",
- " ._27U_m, .yrOIH {",
+ " ._27U_m, ._2XHj8 {",
" border-bottom: 1px solid var(--dark);",
" background-color: var(--darker) !important; }",
" /* Active indicator. */",
@@ -623,6 +624,9 @@
" .message-in > div:not(.a81-s) > div,",
" .message-out > div:not(.a81-s) > div {",
" background-color: var(--darker) !important; }",
+ " /* Message sender bubble. #69 */",
+ " ._3tMyP {",
+ " background-color: var(--darker) !important; }",
" ._2v02G {",
" color: var(--lighter) !important; }",
"",
@@ -674,7 +678,7 @@
" border-radius: 4px;",
" background-color: var(--shadow); }",
" /* Text color. */",
- " .KYpDv ._1DZAH ._3EFt_ {",
+ " .KYpDv ._1DZAH ._3EFt_, ._2MyYN {",
" margin-top: 0px;",
" color: var(--lighter); }",
"",
@@ -793,8 +797,8 @@
" Fixes message content/timestamp overlapping.",
" Apparently they forgot to add nl-specific styles. XD",
" */",
- " html[lang=nl] .EopGb { width: 56px }",
- " html[lang=nl] ._2COY9 { width: 92px }",
+ " html[lang=\'vi\'] .EopGb, html[lang=\'nl\'] .EopGb { width: 56px }",
+ " html[lang=\'vi\'] ._2COY9, html[lang=\'nl\'] ._2COY9 { width: 92px }",
"",
" /* Bubble tails -- experimental. */",
" .tail .tail-container {",
@@ -1466,7 +1470,6 @@
" }",
"",
"",
- " /* Custom CSS rules. */",
" /**",
" * Userstyles.org limitations prevent this; ",
" * Install UserCSS version from GitHub to use it. ",
@@ -1490,6 +1493,7 @@ if (typeof GM_addStyle != "undefined") {
document.documentElement.appendChild(node);
}
}
+// End UserScript
const regexes = [
// en