aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco GuimarĂ£es2020-02-01 15:23:28 -0300
committerFrancisco GuimarĂ£es2020-02-01 15:23:51 -0300
commit9d076c0cf4e512ff7eaec2e53d72aff8e782ea15 (patch)
tree95f54799b65469bdf48d90931371ce326dcce69c
parentbe0d62696fbaa71a3cb0c9e107efb18cdf07e553 (diff)
downloadaur-9d076c0cf4e512ff7eaec2e53d72aff8e782ea15.tar.gz
Adjust new nativefier name logic.
See https://github.com/jiahaog/nativefier/pull/850
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--README.md2
-rw-r--r--whatsapp-nativefier-dark-inject.js4
4 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1cf7e8ae25a..62cbce1c2111 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = whatsapp-nativefier-dark
pkgdesc = WhatsApp desktop built with nativefier (electron) using dark theme
pkgver = 0.20200116224810
- pkgrel = 3
+ pkgrel = 4
url = https://web.whatsapp.com
arch = armv7l
arch = i686
@@ -18,7 +18,7 @@ pkgbase = whatsapp-nativefier-dark
source = whatsapp-nativefier-dark-inject.js
sha256sums = 3899581abcfed9b40b7208bbbca8bdbfe3ae9655980dbf55f04dec9cb3309f27
sha256sums = 61f0033b6ac363699620065b18d54b922bc597c243667adafa61f8545839e0ad
- sha256sums = 6bd5e55c56cc404a4ebb63978ae9c2088b63e06902b0fee578f5358717b2a9ff
+ sha256sums = 27db4de42bdacbd15a46b05311d436c9b3d07563099524615c9c17242c8d3825
pkgname = whatsapp-nativefier-dark
diff --git a/PKGBUILD b/PKGBUILD
index 59ed37e3744f..5f6179d3e0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=whatsapp-nativefier-dark
pkgver=0.20200116224810
-pkgrel=3
+pkgrel=4
pkgdesc="WhatsApp desktop built with nativefier (electron) using dark theme"
arch=("armv7l" "i686" "x86_64")
url="https://web.whatsapp.com"
@@ -17,7 +17,7 @@ source=(
sha256sums=(
"3899581abcfed9b40b7208bbbca8bdbfe3ae9655980dbf55f04dec9cb3309f27"
"61f0033b6ac363699620065b18d54b922bc597c243667adafa61f8545839e0ad"
- "6bd5e55c56cc404a4ebb63978ae9c2088b63e06902b0fee578f5358717b2a9ff"
+ "27db4de42bdacbd15a46b05311d436c9b3d07563099524615c9c17242c8d3825"
)
build() {
@@ -38,8 +38,8 @@ build() {
package() {
install -dm755 "${pkgdir}/"{opt,usr/{bin,share/{applications,licenses/${pkgname}}}}
- cp -rL "${srcdir}/whats-app-linux-"* "${pkgdir}/opt/${pkgname}"
- ln -s "/opt/${pkgname}/whats-app" "${pkgdir}/usr/bin/${pkgname}"
+ cp -rL "${srcdir}/WhatsApp-linux-"* "${pkgdir}/opt/${pkgname}"
+ ln -s "/opt/${pkgname}/WhatsApp" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${pkgdir}/opt/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
diff --git a/README.md b/README.md
index c953441d83a5..2f3fbc9d297c 100644
--- a/README.md
+++ b/README.md
@@ -20,7 +20,7 @@ from the begin of the file until you see the line with comment
- Bump `pkgver` and `pkgrel` at [PKGBUILD](PKGBUILD#L4) accordingly
(see https://wiki.archlinux.org/index.php/PKGBUILD#Version).
-- Run `makepkg --install --force` to check whether the installation works
+- Run `rm -rf pkg/ src/ && makepkg --install --force` to check whether the installation works
successfully.
- Run `makepkg --printsrcinfo > .SRCINFO` to update [.SRCINFO](.SRCINFO).
diff --git a/whatsapp-nativefier-dark-inject.js b/whatsapp-nativefier-dark-inject.js
index fe15bfcea2dd..1887846180ed 100644
--- a/whatsapp-nativefier-dark-inject.js
+++ b/whatsapp-nativefier-dark-inject.js
@@ -1499,9 +1499,9 @@ const regexes = [
// en
/whatsapp works with.*to use whatsapp.*update/i,
// pt
- /o whatsapp funciona com.*para utilizar o whatsapp.*atualize/i
+ /o whatsapp funciona com.*para utilizar o whatsapp.*atualize/i,
// ge
- /whatsapp funktioniert mit.*um whatsapp zu benutzen.*aktualisiere/i,
+ /whatsapp funktioniert mit.*um whatsapp zu benutzen.*aktualisiere/i
]
for (const regex of regexes) {