summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo2020-10-19 17:00:22 +0100
committerGiancarlo2020-10-19 17:00:22 +0100
commite4694f808ea62e3175ddc1f21def9277351c95dd (patch)
tree9cb1a6ac46b8dec6719e7a0055512576c91a2426
parentab3b78974679217e8de324160e50091677c38980 (diff)
downloadaur-e4694f808ea62e3175ddc1f21def9277351c95dd.tar.gz
Add static license
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD11
3 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05f4acc8787e..9f7523bdbb80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = whatsdesk-bin
pkgdesc = unofficial client of whatsapp
pkgver = 0.3.3
- pkgrel = 2
+ pkgrel = 3
url = https://zerkc.gitlab.io/whatsdesk
arch = x86_64
license = MIT
provides = whatsdesk
source_x86_64 = https://zerkc.gitlab.io/whatsdesk/whatsdesk_0.3.3_amd64.deb
+ source_x86_64 = LICENSE
sha256sums_x86_64 = bef797ce3a89f584b12cdc4c10f5d5c6bcb3fa1598c68c9ef2ad39602dcde5b3
+ sha256sums_x86_64 = 38f8c3d94c9497be761fc95f10d3c530a693bae33fa89d5ce29fe1fac45e3aea
pkgname = whatsdesk-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5504a7f7efc9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Gustavo Gonzalez
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9ba641d68593..4d97d072469c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
pkgname=whatsdesk-bin
pkgver=0.3.3
-pkgrel=2
+pkgrel=3
pkgdesc="unofficial client of whatsapp"
arch=('x86_64')
url="https://zerkc.gitlab.io/whatsdesk"
license=('MIT')
provides=('whatsdesk')
-source_x86_64=("${url}/whatsdesk_${pkgver}_amd64.deb")
-sha256sums_x86_64=('bef797ce3a89f584b12cdc4c10f5d5c6bcb3fa1598c68c9ef2ad39602dcde5b3')
+source_x86_64=("${url}/whatsdesk_${pkgver}_amd64.deb"
+ "LICENSE")
+sha256sums_x86_64=('bef797ce3a89f584b12cdc4c10f5d5c6bcb3fa1598c68c9ef2ad39602dcde5b3'
+ '38f8c3d94c9497be761fc95f10d3c530a693bae33fa89d5ce29fe1fac45e3aea')
package() {
bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.xz"
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/whatsdesk/${pkgname%-electron-bin}" "${pkgdir}/usr/bin"
- curl "https://gitlab.com/zerkc/whatsdesk/-/raw/master/LICENSE" -o LICENSE
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}