summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormlatman2016-04-13 17:16:55 -0400
committermlatman2016-04-13 17:16:55 -0400
commit2e60f1e6628c19a9b22dcd10ae6bfa7b05f0d9f5 (patch)
treedd39b1a50262d8b588bf67c63bdb1c766bfb2f1c
downloadaur-2e60f1e6628c19a9b22dcd10ae6bfa7b05f0d9f5.tar.gz
Initial commit
-rw-r--r--.INSTALL22
-rw-r--r--.PKGINFO27
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
4 files changed, 93 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..1c2a04b4292b
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,22 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf /opt/whatsie/whatsie /usr/bin/whatsie
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f /usr/bin/whatsie
+
+ # Delete leftover app data
+ rm -rf "${XDG_CONFIG_HOME:-$HOME/.config}/Whatsie"
+ update-desktop-database -q
+}
diff --git a/.PKGINFO b/.PKGINFO
new file mode 100644
index 000000000000..b2c5fb14f42a
--- /dev/null
+++ b/.PKGINFO
@@ -0,0 +1,27 @@
+pkgname = whatsie
+pkgver = 2.0.10-1
+pkgdesc = A simple & beautiful desktop client for WhatsApp Web.
+url = https://whatsie.chat
+builddate = 1460577681
+packager = whatsie
+arch = x86_64
+size = 140662880
+license =
+backup = etc/xdg/autostart/whatsie.desktop
+depend = bash-completion
+depend = desktop-file-utils
+depend = gconf
+depend = gtk2
+depend = gvfs
+depend = hicolor-icon-theme
+depend = libcap
+depend = libgcrypt
+depend = libgcrypt11
+depend = libnotify
+depend = libsystemd
+depend = libxtst
+depend = nss
+depend = xdg-utils
+optdepend = gir1.2-gnomekeyring-1.0
+optdepend = libgnome-keyring
+optdepend = lsb-release
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0960ef0ab9f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = whatsie
+ pkgver = 2.0.10
+ pkgrel = 1
+ arch = any
+ license = MIT
+ source = https://github.com/mrl4214/AUR/releases/download/2.0.10/whatsie-2.0.10-x86_64.pkg.tar.xz
+ md5sums = 836ac02b4a451a51049b35faffaec425
+
+pkgname = whatsie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9f70043fb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Michael Latman <mlatman@gmail.com>
+pkgname=whatsie
+pkgver=2.0.10
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=('any')
+url=""
+license=('MIT')
+groups=()
+depends=()
+makedepends=('')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/mrl4214/AUR/releases/download/2.0.10/whatsie-2.0.10-x86_64.pkg.tar.xz")
+noextract=()
+md5sums=()
+validpgpkeys=()
+package(){
+cp "whatsie-$pkgver-x86_64.pkg.tar.xz" "$pkgdir/"
+}
+md5sums=('836ac02b4a451a51049b35faffaec425')