summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2016-12-11 00:21:15 +0100
committerBernhard Landauer2016-12-11 00:21:15 +0100
commiteda26f2794512eabf5b2fe6d907fd4e480a4796a (patch)
tree95fb3c5f859e0e923ba20d57642fb514bb0fa026
parenta0edb431e5a98d7dbfd3df4b28fad670a3a3cabb (diff)
downloadaur-eda26f2794512eabf5b2fe6d907fd4e480a4796a.tar.gz
rm .install, proper pkgrel, rm outdated url
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--whatsie.install28
3 files changed, 24 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d34a9d125cdd..ecbc83358f4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Sat Dec 10 23:19:39 UTC 2016
pkgbase = whatsie
pkgdesc = A simple & beautiful desktop client for WhatsApp Web.
pkgver = 2.1.0
- pkgrel = 683
- url = https://whatsie.chat/
- install = whatsie.install
+ pkgrel = 2
+ url = https://github.com/gsantner/whatsie
arch = x86_64
license = MIT
depends = desktop-file-utils
@@ -11,14 +12,14 @@ pkgbase = whatsie
depends = gtk2
depends = gvfs
depends = hicolor-icon-theme
- depends = libgudev
+ depends = libcap
depends = libgcrypt
+ depends = libgudev
depends = libnotify
depends = libxtst
depends = nss
depends = python
depends = xdg-utils
- depends = libcap
optdepends = hunspell: spell check
options = !docs
options = !emptydirs
@@ -26,3 +27,4 @@ pkgbase = whatsie
md5sums = d2e5cb515503cb9e4ae2f574992772c0
pkgname = whatsie
+
diff --git a/PKGBUILD b/PKGBUILD
index 98480f2731b2..cc38202f5e75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,26 @@
pkgname=whatsie
pkgver=2.1.0
-pkgrel=683
+pkgrel=2
pkgdesc="A simple & beautiful desktop client for WhatsApp Web."
arch=('x86_64')
-url="https://whatsie.chat/"
+url="https://github.com/gsantner/$pkgname"
license=('MIT')
-depends=('desktop-file-utils' 'gconf' 'gtk2' 'gvfs' 'hicolor-icon-theme' 'libgudev' 'libgcrypt' 'libnotify' 'libxtst' 'nss' 'python' 'xdg-utils' 'libcap' )
+depends=('desktop-file-utils'
+ 'gconf'
+ 'gtk2'
+ 'gvfs'
+ 'hicolor-icon-theme'
+ 'libcap'
+ 'libgcrypt'
+ 'libgudev'
+ 'libnotify'
+ 'libxtst'
+ 'nss'
+ 'python'
+ 'xdg-utils')
optdepends=('hunspell: spell check' )
options=('!docs' '!emptydirs')
-install=$pkgname.install
-source=("https://dl.bintray.com/aluxian/aur/dist/whatsie-2.1.0-linux-amd64.deb")
-validpgpkeys=('6DDA23616E3FE905FFDA152AE61DA9241537994D')
+source=("https://dl.bintray.com/aluxian/aur/dist/$pkgname-$pkgver-linux-amd64.deb")
md5sums=('d2e5cb515503cb9e4ae2f574992772c0')
package() {
msg2 "Extracting the data.tar.gz..."
@@ -19,5 +29,5 @@ package() {
# Link to the binary
msg2 "Creating symlink..."
mkdir -p "$pkgdir/usr/bin/"
- ln -s /opt/whatsie/whatsie "$pkgdir/usr/bin/whatsie"
+ ln -s /opt/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}
diff --git a/whatsie.install b/whatsie.install
deleted file mode 100644
index 9c896321030c..000000000000
--- a/whatsie.install
+++ /dev/null
@@ -1,28 +0,0 @@
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-
-_update() {
- msg_blue "Updating desktop MIME database..."
- update-desktop-database -q
-
- msg_blue "Updating icon cache..."
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_install() {
- _update
-}
-
-post_upgrade() {
- _update
-}
-
-post_remove() {
- _update
-}