summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-04 21:55:01 +1100
committerPumpkinCheshire2020-11-04 21:55:01 +1100
commit00e9db5d2c3bdc7ec158f11eb355feebff175ac2 (patch)
tree7af562305bb24d6c73e19678d2f7c91f327603ee
parent3abe0e4bd8087a4f80ccc6b89b657b8dd2a07f9a (diff)
downloadaur-00e9db5d2c3bdc7ec158f11eb355feebff175ac2.tar.gz
bump version to 0.5.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5df7a6bac9cb..f955d3341756 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
-# Generated by mksrcinfo v8
-# Sun Dec 10 14:54:03 UTC 2017
pkgbase = whatweb
pkgdesc = Next generation web scanner that identifies what websites are running.
- pkgver = 0.4.9
+ pkgver = 0.5.3
pkgrel = 1
url = http://www.morningstarsecurity.com/research/whatweb
arch = i686
arch = x86_64
license = GPL
- depends = ruby1.8
+ depends = ruby
+ depends = ruby-addressable
+ optdepends = ruby-rake: development test use
+ optdepends = ruby-rdoc: development test use
+ optdepends = ruby-minitest: development test use
+ optdepends = ruby-rubocop: development test use
+ optdepends = ruby-bundler-audit: development test use
+ optdepends = ruby-pry: debugging
+ provides = whatweb
conflicts = whatweb-git
- source = https://github.com/urbanadventurer/WhatWeb/archive/v0.4.9.tar.gz
- md5sums = 31d57457f34f6691ac20639ffdef8ad6
+ source = https://github.com/urbanadventurer/WhatWeb/archive/v0.5.3.tar.gz
+ sha256sums = b4fc61455f1322862f47448835a25437746c9bd6ecca60f7a5c2166373ec77be
pkgname = whatweb
diff --git a/PKGBUILD b/PKGBUILD
index 8ba1d1111ede..339c526d75fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,36 @@
-# Maintainer: robertfoster
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+# Contributor: robertfoster
pkgname=whatweb
-pkgver=0.4.9
+_name=WhatWeb
+pkgver=0.5.3
pkgrel=1
pkgdesc="Next generation web scanner that identifies what websites are running."
arch=('i686' 'x86_64')
url="http://www.morningstarsecurity.com/research/whatweb"
license=('GPL')
-depends=('ruby1.8')
+provides=('whatweb')
+depends=('ruby' 'ruby-addressable')
+optdepends=('ruby-rake: development test use'
+ 'ruby-rdoc: development test use'
+ 'ruby-minitest: development test use'
+ 'ruby-rubocop: development test use'
+ 'ruby-bundler-audit: development test use'
+ 'ruby-pry: debugging')
conflicts=('whatweb-git')
source=("https://github.com/urbanadventurer/WhatWeb/archive/v$pkgver.tar.gz")
+sha256sums=('b4fc61455f1322862f47448835a25437746c9bd6ecca60f7a5c2166373ec77be')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+ sed -i '/bundle install/d' Makefile
+ sed -i "s|require 'lib/whatweb'|require '/usr/share/whatweb/lib/whatweb'|" whatweb
+}
+
package() {
- cd "$srcdir/WhatWeb-$pkgver"
- make DESTDIR=$pkgdir
- sed 's#/usr/bin/env ruby#/usr/bin/ruby-1.8#g' -i ${pkgdir}/usr/bin/whatweb
+ cd "$srcdir/$_name-$pkgver"
+ make DESTDIR=$pkgdir install
}
-md5sums=('31d57457f34f6691ac20639ffdef8ad6')
+