summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-12-15 16:58:16 +1100
committerPumpkinCheshire2020-12-15 16:58:16 +1100
commit29d65460e096eedb5ba5d23b8068a184963a6b23 (patch)
treefda748270c51ea407e02c8b9132ad079cc5f3f91
parent3ed3c578a4adfb346d034fb179a0afa3c2816508 (diff)
downloadaur-29d65460e096eedb5ba5d23b8068a184963a6b23.tar.gz
bump to 0.5.4
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD23
3 files changed, 17 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f955d3341756..37b7cb9469a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = whatweb
pkgdesc = Next generation web scanner that identifies what websites are running.
- pkgver = 0.5.3
+ pkgver = 0.5.4
pkgrel = 1
url = http://www.morningstarsecurity.com/research/whatweb
- arch = i686
arch = x86_64
license = GPL
depends = ruby
@@ -16,8 +15,8 @@ pkgbase = whatweb
optdepends = ruby-pry: debugging
provides = whatweb
conflicts = whatweb-git
- source = https://github.com/urbanadventurer/WhatWeb/archive/v0.5.3.tar.gz
- sha256sums = b4fc61455f1322862f47448835a25437746c9bd6ecca60f7a5c2166373ec77be
+ source = https://github.com/urbanadventurer/WhatWeb/archive/v0.5.4.tar.gz
+ sha256sums = 73e1b8592bf5a15f8a66fffe2408732c434b7068f5d3379cc889fad14ea513ee
pkgname = whatweb
diff --git a/.gitignore b/.gitignore
index 78b3a645e298..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,15 +1,4 @@
-*.log
-*.rpm
-*.deb
-*.tar*
-*.gz
-*.zip
-*.run
-*.whl
-*.AppImage
-*.jar
-*.tgz
-*.pdf
-
-src/
-pkg/
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 339c526d75fd..d65da1624d18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
pkgname=whatweb
_name=WhatWeb
-pkgver=0.5.3
+pkgver=0.5.4
pkgrel=1
pkgdesc="Next generation web scanner that identifies what websites are running."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.morningstarsecurity.com/research/whatweb"
license=('GPL')
provides=('whatweb')
depends=('ruby' 'ruby-addressable')
optdepends=('ruby-rake: development test use'
- 'ruby-rdoc: development test use'
- 'ruby-minitest: development test use'
- 'ruby-rubocop: development test use'
- 'ruby-bundler-audit: development test use'
- 'ruby-pry: debugging')
+ 'ruby-rdoc: development test use'
+ 'ruby-minitest: development test use'
+ 'ruby-rubocop: development test use'
+ 'ruby-bundler-audit: development test use'
+ 'ruby-pry: debugging')
conflicts=('whatweb-git')
source=("https://github.com/urbanadventurer/WhatWeb/archive/v$pkgver.tar.gz")
-sha256sums=('b4fc61455f1322862f47448835a25437746c9bd6ecca60f7a5c2166373ec77be')
+sha256sums=('73e1b8592bf5a15f8a66fffe2408732c434b7068f5d3379cc889fad14ea513ee')
prepare() {
cd "$srcdir/$_name-$pkgver"
@@ -27,10 +27,7 @@ prepare() {
sed -i "s|require 'lib/whatweb'|require '/usr/share/whatweb/lib/whatweb'|" whatweb
}
-
package() {
- cd "$srcdir/$_name-$pkgver"
- make DESTDIR=$pkgdir install
+ cd "$srcdir/$_name-$pkgver"
+ make DESTDIR=$pkgdir install
}
-
-