summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:41:37 +0200
committerM0Rf302015-06-17 16:41:37 +0200
commitd919ac1600d8184c9e72bec36905850b00fb168b (patch)
treef0e31618c99d66350f4dcd12bcde547555228990
downloadaur-d919ac1600d8184c9e72bec36905850b00fb168b.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..381a177f83cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = whatweb-git
+ pkgdesc = Next generation web scanner that identifies what websites are running.
+ pkgver = 3955.362145c
+ pkgrel = 1
+ url = http://www.morningstarsecurity.com/research/whatweb
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ruby1.8
+ conflicts = whatweb
+ source = whatweb::git://github.com/urbanadventurer/WhatWeb.git
+ md5sums = SKIP
+
+pkgname = whatweb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a3bb8414d3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: M0Rf30
+
+pkgname=whatweb-git
+pkgver=3955.362145c
+pkgrel=1
+pkgdesc="Next generation web scanner that identifies what websites are running."
+arch=('i686' 'x86_64')
+conflicts=('whatweb')
+url="http://www.morningstarsecurity.com/research/whatweb"
+license=('GPL')
+depends=('ruby1.8')
+source=("whatweb::git://github.com/urbanadventurer/WhatWeb.git")
+
+package() {
+ cd whatweb
+ sed -i 's/TODO //g' Makefile
+ make DESTDIR=$pkgdir install
+ sed 's#/usr/bin/env ruby#/usr/bin/ruby-1.8#g' -i ${pkgdir}/usr/bin/whatweb
+
+}
+
+pkgver() {
+ cd whatweb
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')