summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Wilper2017-04-08 23:46:59 +0200
committerSimon Wilper2017-04-08 23:46:59 +0200
commit06d7e8d8994bedb9ecc23c166b6974fd721d97d7 (patch)
tree7a50ab588703cd8c582a77f3376c63f944767b55
downloadaur-06d7e8d8994bedb9ecc23c166b6974fd721d97d7.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD51
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..472b330eaa7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = whatwg-html-git
+ pkgdesc = Clone the WHATWG HTML specification with local resources
+ pkgver = latest
+ pkgrel = 1
+ url = https://whatwg.org/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = perl
+ source = git+https://www.github.com/simonaw/whatwg-html.git
+ md5sums = SKIP
+
+pkgname = whatwg-html-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be515519b1c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Simon Wilper <sxw@chronowerks.de>
+pkgname=whatwg-html-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Clone the WHATWG HTML specification with local resources"
+arch=('any')
+url="https://whatwg.org/"
+license=('GPL')
+makedepends=(git perl)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(git+https://www.github.com/simonaw/whatwg-html.git)
+noextract=()
+md5sums=('SKIP')
+
+_gitroot=https://www.github.com/simonaw/whatwg-html.git
+_gitname=whatwg-html
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ ./run
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+
+ mkdir -p ${pkgdir}/usr/share/doc/whatwg
+ cp -rv html-build/output/multipage ${pkgdir}/usr/share/doc/whatwg/html
+}
+
+# vim:set ts=2 sw=2 et: