summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRihards Skuja2016-12-21 16:00:21 +0200
committerRihards Skuja2016-12-21 16:00:21 +0200
commite359804b007b04fdd6f6ed39d44d59d59da5b0e9 (patch)
tree657fc19f1276f456620e2984dae74e7dd49ca514
parenta9c5a8314ec92a553290f0e1ee63afab9ce5aa6d (diff)
downloadaur-e359804b007b04fdd6f6ed39d44d59d59da5b0e9.tar.gz
Standard variable usage
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06ae5ec5a434..e338c39981f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: Rihards Skuja <rskuja@gmail.com>
-_pkgname=when-changed
-pkgname=$_pkgname-git
+pkgname=when-changed-git
pkgver=0.r62.7a2df66
pkgrel=1
pkgdesc="Execute a command when a file is changed."
@@ -9,17 +8,17 @@ url="https://github.com/joh/when-changed"
license=('BSD')
depends=('python2' 'watchdog')
makedepends=('git')
-provides=($_pkgname)
-conflicts=($_pkgname)
+provides=(when-changed)
+conflicts=(when-changed)
source=('git+https://github.com/joh/when-changed.git')
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd when-changed
echo "0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
package() {
- cd $_pkgname
+ cd when-changed
python2 setup.py install --root="$pkgdir" --optimize=1
}