summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Porivaev2016-10-27 10:58:29 +0300
committerSergey Porivaev2016-10-27 10:58:29 +0300
commitb08ab2ac023826e8e1bf054709311c06e2fe5a17 (patch)
tree0b5ec8d97115650b97b7ecb1051d816cf483efdd
downloadaur-b08ab2ac023826e8e1bf054709311c06e2fe5a17.tar.gz
Created whereami pkgbuild
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7388ffb86b76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = whereami-git
+ pkgdesc = Uses WiFi signals and machine learning to predict where you are
+ pkgver = r49.a782f9e
+ pkgrel = 1
+ url = https://github.com/kootenpv/whereami
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-access_points
+ depends = python-tqdm
+ depends = python-scikit-learn
+ provides = whereami
+ conflicts = whereami
+ source = git+https://github.com/kootenpv/whereami
+ md5sums = SKIP
+
+pkgname = whereami-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..558cf54c5e8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sergey Porivaev <porivaevs at gmail dot com>
+
+pkgname=whereami-git
+pkgver=r49.a782f9e
+pkgrel=1
+pkgdesc='Uses WiFi signals and machine learning to predict where you are'
+arch=('any')
+url='https://github.com/kootenpv/whereami'
+license=('MIT')
+depends=('python' 'python-access_points' 'python-tqdm' 'python-scikit-learn')
+makedepends=('git')
+provides=('whereami')
+conflicts=('whereami')
+source=('git+https://github.com/kootenpv/whereami')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}