summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAneesh Raghavan2018-05-24 08:04:00 -0700
committerAneesh Raghavan2018-05-24 08:04:00 -0700
commit03a2f313030bf6ec56c57c9a284215d5f095aae0 (patch)
treea02bc58f17b403df67974bd88f3bb86d1c8e3dc1
downloadaur-03a2f313030bf6ec56c57c9a284215d5f095aae0.tar.gz
Upload the packages
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb6395d58f8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = whip
+ pkgdesc = Whip, the who, what, where and when about IP address data
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/wbolster/whip
+ arch = any
+ license = BSD
+ makedepends = python3
+ depends = python
+ source = https://files.pythonhosted.org/packages/1a/a6/a4cf9dbe303f317a020b9b6b6cf7aebbf773926cd970be6cffc21e00c88c/whip-0.1.tar.gz
+ md5sums = 03fe9650cad2bb0ddee78bedf0f12065
+
+pkgname = whip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..720d1b0be63f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Aneesh Raghavan <(first name without "h")(last name) @ gmail.com>
+#Automatically generated by pip2arch on 2018-05-23
+
+pkgname=whip
+pkgver=0.1
+pkgrel=1
+pkgdesc="Whip, the who, what, where and when about IP address data"
+url="https://github.com/wbolster/whip"
+depends=('python' )
+makedepends=('python3' )
+license=('BSD')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/1a/a6/a4cf9dbe303f317a020b9b6b6cf7aebbf773926cd970be6cffc21e00c88c/whip-0.1.tar.gz')
+md5sums=('03fe9650cad2bb0ddee78bedf0f12065')
+
+build() {
+ cd $srcdir/whip-0.1
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/whip-0.1
+ python setup.py install --root="$pkgdir" --optimize=1
+}