summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastien Traverse2016-10-23 19:56:22 +0200
committerBastien Traverse2016-10-23 19:59:45 +0200
commit1243adbccc255a96be0ebbed74098c5ad3d9b391 (patch)
tree34636e4bc85640ffd988525e55948f21e887fd2c
parent400272028466c80b3472bb60b34ddd395f7bb560 (diff)
downloadaur-1243adbccc255a96be0ebbed74098c5ad3d9b391.tar.gz
Update to tag v0.2.4 and add post_upgrade warning about backward incompatible changes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--whipper-git.install16
3 files changed, 37 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be99670d5b2f..cfd60ced1e6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,28 @@
# Generated by mksrcinfo v8
-# Sun Aug 28 14:28:51 UTC 2016
+# Sun Oct 23 17:59:35 UTC 2016
pkgbase = whipper-git
pkgdesc = A Unix CD ripper aiming for accuracy over speed -- forked from morituri
- pkgver = 0.2.3.r43.g89f3ba3
+ pkgver = 0.2.3.r101.gd7f8557
pkgrel = 1
url = https://github.com/JoeLametta/whipper
+ install = whipper-git.install
arch = any
license = GPL3
makedepends = git
makedepends = python2-gobject2
- makedepends = python2-musicbrainzngs
- makedepends = python2-setuptools
+ depends = accuraterip-checksum
+ depends = cddb-py
depends = cdparanoia
depends = cdrdao
depends = gstreamer0.10-base
depends = gstreamer0.10-base-plugins
depends = gstreamer0.10-good-plugins
depends = gstreamer0.10-python
+ depends = libsndfile
+ depends = python2-musicbrainzngs
depends = python2-pycdio
- optdepends = cddb-py: for showing but not using disc info if not in MusicBrainz
- optdepends = python2-musicbrainzngs: for metadata lookup
- optdepends = python2-setuptools: for plugin support
+ depends = python2-setuptools
+ depends = sox
provides = morituri
conflicts = morituri
conflicts = morituri-git
diff --git a/PKGBUILD b/PKGBUILD
index be03cccc0dcd..62670c7c6043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Bastien Traverse <firstname at lastname dot email>
+# Contributor: Samantha Baldwin <fuhsaz+git@cryptic.li>
# Contributor: Frederik "Freso" S. Olesen <archlinux@freso.dk>
# Contributor: Caleb Reach <jtxx000@gmail.com>
# Contributor: Felix Yan <felixonmars@gmail.com>
@@ -8,34 +9,35 @@
pkgname=whipper-git
_gitname=whipper
-pkgver=0.2.3.r77.g3881079
+pkgver=0.2.3.r101.gd7f8557
pkgrel=1
pkgdesc="A Unix CD ripper aiming for accuracy over speed -- forked from morituri"
arch=('any')
url="https://github.com/JoeLametta/whipper"
license=('GPL3')
depends=(
+ 'accuraterip-checksum' # for accuraterip-checksum calculation
+ 'cddb-py' # for showing but not using disc info if not in MusicBrainz (issue #28)
'cdparanoia' # for the actual ripping
'cdrdao' # for session, TOC, pregap, and ISRC extraction
'gstreamer0.10-base' # for encoding
'gstreamer0.10-base-plugins' # for appsink
'gstreamer0.10-good-plugins' # for wav encoding
'gstreamer0.10-python' # for encoding
+ 'libsndfile' # for reading wav files (pulls in flac, also required for reading flac files)
+ 'python2-musicbrainzngs' # for metadata lookup
'python2-pycdio' # for storing drive identification in config file
+ 'python2-setuptools' # for plugin support
+ 'sox' # for track peak detection'
)
makedepends=(
'git'
'python2-gobject2'
- 'python2-musicbrainzngs'
- 'python2-setuptools'
)
-optdepends=(
- 'cddb-py: for showing but not using disc info if not in MusicBrainz'
- 'python2-musicbrainzngs: for metadata lookup'
- 'python2-setuptools: for plugin support'
-)
+optdepends=()
provides=('morituri')
conflicts=('morituri' 'morituri-git')
+install=$pkgname.install
source=('git+https://github.com/JoeLametta/whipper.git')
md5sums=('SKIP')
@@ -54,15 +56,12 @@ prepare() {
build() {
cd "$srcdir/$_gitname"
export PYTHON=$(which python2)
- ./autogen.sh --prefix=/usr --sysconfdir=/etc
- ./configure --prefix=/usr --sysconfdir=/etc
- make
+ python2 setup.py build
}
package() {
cd "$srcdir/$_gitname"
- make DESTDIR="$pkgdir/" install
- install -Dm 0644 "README.md" "$pkgdir/usr/share/doc/$_gitname/README"
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1
}
# vim: ft=sh:ts=4:sw=4:et
diff --git a/whipper-git.install b/whipper-git.install
new file mode 100644
index 000000000000..50b28daf5a6c
--- /dev/null
+++ b/whipper-git.install
@@ -0,0 +1,16 @@
+post_upgrade() {
+ # As of v0.2.4 (commit 746dc6599, 2016-10-09), backward-incompatible changes
+ # were introduced as documented into the README file.
+ # Warn users about the need to check their config:
+ if [ $(vercmp $2 0.2.4) -lt 0 ]; then
+ cat<<WARN
+**WARNING**: As of v0.2.4 (commit 746dc6599, 2016-10-09), backward incompatible
+changes were introduced concerning config/cache/state file paths, to follow the
+XDG standard and substitute every "morituri" occurrence by the fork name
+"whipper".
+This means that all previous configuration won't be reused after the upgrade
+without a manual intervention to use the new file paths.
+See the official README for details: https://github.com/JoeLametta/whipper#backward-incompatible-changes.
+WARN
+ fi
+}