summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastien Traverse2016-12-11 16:38:02 +0100
committerBastien Traverse2016-12-11 16:38:02 +0100
commit4292415a323087ce3bd98d783a4504a8aa430bef (patch)
tree158c0ec5d621c95b403b7d608fb4029c3f9a8129
parent0bc53a402dfd70e063b710507e9d36e1aef76bcb (diff)
downloadaur-4292415a323087ce3bd98d783a4504a8aa430bef.tar.gz
Bump pkgver to latest rev (0.4) and improve PKGBUILD
replace non-standard _gitname variable with string processing bump pkgver to latest major version (v0.4) remove empty optdepends() array remove conflict=() with morituri since whipper uses its own namespace now remove .install file after 7-week warning of backward-incompatible changes parametrize source array to use $pkgname and $url variables (makes it portable accross PKGBUILDs) remove vim options line as it does not appear in reference PKGBUILD.proto
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--whipper-git.install16
3 files changed, 10 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 872414b7cf28..0292b4803ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Nov 3 19:37:49 UTC 2016
+# Sun Dec 11 15:37:49 UTC 2016
pkgbase = whipper-git
pkgdesc = A Unix CD ripper aiming for accuracy over speed -- forked from morituri
- pkgver = 0.2.3.r112.g5a59f3c
+ pkgver = 0.4.0.r3.g71335e1
pkgrel = 1
url = https://github.com/JoeLametta/whipper
- install = whipper-git.install
arch = any
license = GPL3
makedepends = git
@@ -24,9 +23,8 @@ pkgbase = whipper-git
depends = python2-setuptools
depends = sox
provides = whipper
- conflicts = morituri
conflicts = whipper
- source = git+https://github.com/JoeLametta/whipper.git
+ source = whipper::git+https://github.com/JoeLametta/whipper.git
md5sums = SKIP
pkgname = whipper-git
diff --git a/PKGBUILD b/PKGBUILD
index 57c08ca74922..7f2512ea8123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,7 @@
# Based on community/morituri and aur/morituri-git PKGBUILDs
pkgname=whipper-git
-_gitname=whipper
-pkgver=0.2.3.r112.g5a59f3c
+pkgver=0.4.0.r3.g71335e1
pkgrel=1
pkgdesc="A Unix CD ripper aiming for accuracy over speed -- forked from morituri"
arch=('any')
@@ -34,34 +33,30 @@ makedepends=(
'git'
'python2-gobject2'
)
-optdepends=()
provides=('whipper')
-conflicts=('morituri' 'whipper')
-install=$pkgname.install
-source=('git+https://github.com/JoeLametta/whipper.git')
+conflicts=('whipper')
+source=("${pkgname/-git}::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
# Cutting off "v" prefix present in the git tag
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
git submodule init
git submodule update
}
build() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
export PYTHON=$(which python2)
python2 setup.py build
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/${pkgname/-git}"
python2 setup.py install --root="${pkgdir}"/ --optimize=1
}
-
-# vim: ft=sh:ts=4:sw=4:et
diff --git a/whipper-git.install b/whipper-git.install
deleted file mode 100644
index 50b28daf5a6c..000000000000
--- a/whipper-git.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_upgrade() {
- # As of v0.2.4 (commit 746dc6599, 2016-10-09), backward-incompatible changes
- # were introduced as documented into the README file.
- # Warn users about the need to check their config:
- if [ $(vercmp $2 0.2.4) -lt 0 ]; then
- cat<<WARN
-**WARNING**: As of v0.2.4 (commit 746dc6599, 2016-10-09), backward incompatible
-changes were introduced concerning config/cache/state file paths, to follow the
-XDG standard and substitute every "morituri" occurrence by the fork name
-"whipper".
-This means that all previous configuration won't be reused after the upgrade
-without a manual intervention to use the new file paths.
-See the official README for details: https://github.com/JoeLametta/whipper#backward-incompatible-changes.
-WARN
- fi
-}