summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReily Siegel2019-06-25 04:53:58 -0400
committerReily Siegel2019-06-25 04:53:58 -0400
commit3d4cb4b68460a110da18285cac1102d84483cd00 (patch)
tree373f488b04ad5dc978e49af6ed52b57288b9dd29
parentd94b264ebef5069a998d5316d25986fcdb8c4bf6 (diff)
downloadaur-3d4cb4b68460a110da18285cac1102d84483cd00.tar.gz
Add custom LICENSE and needed deps.
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD16
3 files changed, 44 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8546baa2bf5d..9e6aab3fa8ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,19 @@
pkgbase = whirlpool-gui-bin
pkgdesc = Desktop GUI for Whirlpool by Samourai-Wallet.
pkgver = 0.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Samourai-Wallet/whirlpool-gui/
arch = x86_64
- license = Unlicense
+ license = custom:Unlicense
+ depends = dbus
+ depends = glib2
+ depends = hicolor-icon-theme
+ depends = java-runtime
+ depends = nss
source = https://github.com/Samourai-Wallet/whirlpool-gui/releases/download/0.6.4/whirlpool-gui_0.6.4_amd64.deb
+ source = LICENSE
sha512sums = acb3003613dfd5478026d15a24745b41308f3fe1911ea07021ef232c2fc774858f7b336909deb71732dee16972745929a448368be8f2da7952f3dbd01266b82b
+ sha512sums = 6db610810f1b22a21ef217b4b6ace78dd5a4f427be3e6934a5770b64d019c0699459ea433b7117e955aac3feea02bd703fba2892a7961e27b2c0de859f68d7d7
pkgname = whirlpool-gui-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..cf1ab25da034
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
index f9afa6cf016e..dff5b484f674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
# Maintainer: Reily Siegel <mail@reilysiegel.com>
pkgname=whirlpool-gui-bin
pkgver=0.6.4
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop GUI for Whirlpool by Samourai-Wallet."
arch=('x86_64')
url="https://github.com/Samourai-Wallet/whirlpool-gui/"
-license=('Unlicense')
-depends=()
-source=("https://github.com/Samourai-Wallet/whirlpool-gui/releases/download/0.6.4/whirlpool-gui_${pkgver}_amd64.deb")
-sha512sums=('acb3003613dfd5478026d15a24745b41308f3fe1911ea07021ef232c2fc774858f7b336909deb71732dee16972745929a448368be8f2da7952f3dbd01266b82b')
+license=('custom:Unlicense')
+depends=('dbus' 'glib2' 'hicolor-icon-theme' 'java-runtime' 'nss')
+source=("https://github.com/Samourai-Wallet/whirlpool-gui/releases/download/0.6.4/whirlpool-gui_${pkgver}_amd64.deb"
+ LICENSE)
+sha512sums=('acb3003613dfd5478026d15a24745b41308f3fe1911ea07021ef232c2fc774858f7b336909deb71732dee16972745929a448368be8f2da7952f3dbd01266b82b'
+ '6db610810f1b22a21ef217b4b6ace78dd5a4f427be3e6934a5770b64d019c0699459ea433b7117e955aac3feea02bd703fba2892a7961e27b2c0de859f68d7d7')
package(){
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
+
+ # Install LICENSE
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}