summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-16 17:00:21 +0800
committerzxp198210052023-11-16 17:00:21 +0800
commit17cd120206778d76e0a24dde74ba8b27a0a6200f (patch)
tree6ec95a77384770b2e97e38fa43ed104c4c0abaf7
parent55c1aae756cb1416e1bcf80a11ef9775f6b49f7e (diff)
downloadaur-17cd120206778d76e0a24dde74ba8b27a0a6200f.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD37
2 files changed, 30 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dba02abd25f..023721b18866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = whisperpix-bin
pkgdesc = Add comments to your photos with your voice
pkgver = 1.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/graham-walker/WhisperPix
arch = x86_64
license = MIT
@@ -11,7 +11,6 @@ pkgbase = whisperpix-bin
depends = libdrm
depends = pango
depends = libcups
- depends = dbus
depends = alsa-lib
depends = libx11
depends = libxdamage
@@ -21,14 +20,12 @@ pkgbase = whisperpix-bin
depends = libxcomposite
depends = mesa
depends = libxfixes
- depends = glib2
depends = nss
- depends = gcc-libs
depends = libxcb
depends = expat
- depends = glibc
depends = libxrandr
depends = gtk3
+ depends = perl
provides = whisperpix=1.1.0
conflicts = whisperpix
source = whisperpix-1.1.0.deb::https://github.com/graham-walker/WhisperPix/releases/download/v1.1.0/whisperpix_1.1.0_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index ae1108ba27ad..c9b8381cb5ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,44 @@
pkgname=whisperpix-bin
_pkgname=WhisperPix
pkgver=1.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Add comments to your photos with your voice"
arch=('x86_64')
url="https://github.com/graham-walker/WhisperPix"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('libxext' 'nspr' 'hicolor-icon-theme' 'libdrm' 'pango' 'libcups' 'dbus' 'alsa-lib' 'libx11' 'libxdamage' \
- 'cairo' 'libxkbcommon' 'at-spi2-core' 'libxcomposite' 'mesa' 'libxfixes' 'glib2' 'nss' 'gcc-libs' 'libxcb' 'expat' \
- 'glibc' 'libxrandr' 'gtk3')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/graham-walker/WhisperPix/v${pkgver}/LICENSE")
+depends=(
+ 'libxext'
+ 'nspr'
+ 'hicolor-icon-theme'
+ 'libdrm'
+ 'pango'
+ 'libcups'
+ 'alsa-lib'
+ 'libx11'
+ 'libxdamage'
+ 'cairo'
+ 'libxkbcommon'
+ 'at-spi2-core'
+ 'libxcomposite'
+ 'mesa'
+ 'libxfixes'
+ 'nss'
+ 'libxcb'
+ 'expat'
+ 'libxrandr'
+ 'gtk3'
+ 'perl'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/graham-walker/WhisperPix/v${pkgver}/LICENSE"
+)
sha256sums=('f5c0b5b52505f4ad5fa6b72556ca19adbe559a70cf2534d1000ad204706c09e6'
'5fc34925726421c2268a2a719ceebe463aef8ad39480b1d08daee3044fd6381e')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
- asar e "${srcdir}/opt/${_pkgname}/resources/app.asar" "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked"
- asar p "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked" "${srcdir}/opt/${_pkgname}/resources/app.asar"
- rm -rf "${srcdir}/opt/${_pkgname}/resources/app.asar.unpacked"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin} --no-sandbox|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {