summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2019-11-06 13:06:38 -0500
committerSamuel Mesa2019-11-06 13:06:38 -0500
commitc81f2e0dea3309ca11a71b165dbfca6ba1920291 (patch)
tree32f982e075516ef178fa7c89006c1f412fb9f41e
downloadaur-c81f2e0dea3309ca11a71b165dbfca6ba1920291.tar.gz
First version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c11ffaf2a871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = whitebox-tools
+ pkgdesc = WhiteboxTools is an advanced geospatial data analysis platform developed by Prof. John Lindsay
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://jblindsay.github.io/ghrg/WhiteboxTools/index.html
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ depends = python
+ source = https://github.com/jblindsay/whitebox-tools/archive/v1.0.2.tar.gz
+ sha256sums = d53dd8a8390f4d0883b5d66d776cc20418802f9fae48f80bd817da14d03c22cf
+
+pkgname = whitebox-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed9e81bd5b8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
+
+pkgname=whitebox-tools
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="WhiteboxTools is an advanced geospatial data analysis platform developed by Prof. John Lindsay"
+arch=(i686 x86_64)
+url="https://jblindsay.github.io/ghrg/WhiteboxTools/index.html"
+license=('MIT')
+makedepends=('rust')
+depends=('python')
+source=("https://github.com/jblindsay/whitebox-tools/archive/v${pkgver}.tar.gz")
+sha256sums=('d53dd8a8390f4d0883b5d66d776cc20418802f9fae48f80bd817da14d03c22cf')
+
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ cargo install --path . --root="${pkgdir}/usr"
+ rm "${pkgdir}/usr/.crates.toml"
+} \ No newline at end of file