summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2021-10-25 19:50:44 +0800
committerKaizhao Zhang2021-10-25 19:50:44 +0800
commit1744ee19d5d0021fcb8285c294a4442a3b41bcfe (patch)
treea0f37d2fe9c77e463b0a86f74d79c78eaf50a812
downloadaur-1744ee19d5d0021fcb8285c294a4442a3b41bcfe.tar.gz
Initial import with version 2021.10.21 (2021-10-21)
This is ported from whitesur-gtk-theme-git package without any customization options.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--whitesur-gtk-theme.install9
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d47d180f7b51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = whitesur-gtk-theme
+ pkgdesc = A macOS BigSur-like theme for your GTK apps
+ pkgver = 2021.10.21
+ pkgrel = 1
+ url = https://github.com/vinceliuice/WhiteSur-gtk-theme
+ install = whitesur-gtk-theme.install
+ arch = any
+ license = MIT
+ makedepends = sassc
+ optdepends = gtk-engine-murrine: GTK2 theme support
+ optdepends = gtk-engines: GTK2 theme support
+ optdepends = whitesur-icon-theme: matching icon theme
+ optdepends = whitesur-cursor-theme: matching cursor theme
+ conflicts = whitesur-gtk-theme-git
+ source = whitesur-gtk-theme-2021-10-21.tar.gz::https://github.com/vinceliuice/WhiteSur-gtk-theme/archive/2021-10-21.tar.gz
+ sha256sums = 13508b65b8cfc70023a4425944340cff4814106edfeadd9336bfbcb787b8320f
+
+pkgname = whitesur-gtk-theme
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f064cc7e2f7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!.gitignore
+!PKGBUILD
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcb2fee4f3a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+
+_pkgname=WhiteSur-gtk-theme
+_pkgver=2021-10-21
+
+pkgname=whitesur-gtk-theme
+pkgver="${_pkgver//-/.}"
+pkgrel=1
+pkgdesc="A macOS BigSur-like theme for your GTK apps"
+arch=('any')
+url="https://github.com/vinceliuice/WhiteSur-gtk-theme"
+license=('MIT')
+makedepends=('sassc')
+optdepends=(
+ 'gtk-engine-murrine: GTK2 theme support'
+ 'gtk-engines: GTK2 theme support'
+ 'whitesur-icon-theme: matching icon theme'
+ 'whitesur-cursor-theme: matching cursor theme'
+)
+conflicts=("${pkgname}-git")
+install="${pkgname}.install"
+source=(
+ "${pkgname}-${_pkgver}.tar.gz::${url}/archive/${_pkgver}.tar.gz"
+)
+sha256sums=(
+ '13508b65b8cfc70023a4425944340cff4814106edfeadd9336bfbcb787b8320f'
+)
+
+package() {
+ cd "${_pkgname}-${_pkgver}"
+ install -d "${pkgdir}/usr/share/themes"
+
+ # See for more customization options:
+ # https://github.com/vinceliuice/WhiteSur-gtk-theme#theres-so-many-customizations-you-can-do
+ ./install.sh \
+ --dest "${pkgdir}/usr/share/themes"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/whitesur-gtk-theme.install b/whitesur-gtk-theme.install
new file mode 100644
index 000000000000..d53a822a2ae1
--- /dev/null
+++ b/whitesur-gtk-theme.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ""
+ echo "XFCE: remember to run 'xfce4-panel -r' every time you switch themes to fix the panel opacity."
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}