summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-07-14 12:11:05 -0600
committerMark Wagie2020-07-14 12:11:05 -0600
commit180981fb0db8d9330322ab9ffacc3de496a52ed9 (patch)
tree8add3f5f575ecb23f8c4f5083c0477d6ee51ba3e
downloadaur-180981fb0db8d9330322ab9ffacc3de496a52ed9.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95bb8122ea6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = whitesur-gtk-theme-git
+ pkgdesc = MacOS Big Sur like theme for Gnome desktops
+ pkgver = r1.d4796a6
+ pkgrel = 1
+ url = https://github.com/vinceliuice/WhiteSur-gtk-theme
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = sassc
+ makedepends = optipng
+ makedepends = inkscape
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ depends = gtk3
+ optdepends = mcmojave-circle-icon-theme: matching icon theme
+ optdepends = mcmojave-cursors: matching cursor theme
+ optdepends = plank: for included plank theme
+ provides = whitesur-gtk-theme
+ conflicts = whitesur-gtk-theme
+ options = !strip
+ source = whitesur-gtk-theme::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git
+ sha256sums = SKIP
+
+pkgname = whitesur-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cadd2c581e77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=whitesur-gtk-theme-git
+pkgver=r1.d4796a6
+pkgrel=1
+pkgdesc="MacOS Big Sur like theme for Gnome desktops"
+arch=('any')
+url="https://github.com/vinceliuice/WhiteSur-gtk-theme"
+license=('GPL')
+depends=('gtk-engine-murrine' 'gtk-engines' 'gtk3')
+makedepends=('git' 'sassc' 'optipng' 'inkscape')
+optdepends=('mcmojave-circle-icon-theme: matching icon theme'
+ 'mcmojave-cursors: matching cursor theme'
+ 'plank: for included plank theme')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip')
+source=("${pkgname%-git}::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/themes"
+ ./install.sh -d "$pkgdir/usr/share/themes"
+
+ install -Dm644 src/other/plank/theme-dark/* -t \
+ "$pkgdir/usr/share/plank/themes/WhiteSur-dark"
+ install -Dm644 src/other/plank/theme-light/* -t \
+ "$pkgdir/usr/share/plank/themes/WhiteSur-light"
+}