summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-27 08:41:24 -0600
committerMark Wagie2021-07-27 08:41:24 -0600
commit34b2d71844ca9b9c8f6492695c5eca777a475fa8 (patch)
tree378a38593ab479c3c05fbf7d6453102d779c8835
parentb730f89440128832804c27f869592127b0b5ca96 (diff)
downloadaur-34b2d71844ca9b9c8f6492695c5eca777a475fa8.tar.gz
adjust build deps
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 808294c0ab82..3a792fba98e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = whitesur-gtk-theme-git
pkgdesc = MacOS Big Sur like theme for GNOME desktops
- pkgver = 2021.05.05.r68.g474b0ec
+ pkgver = 2021.06.23.r87.gc790fa2
pkgrel = 1
url = https://github.com/vinceliuice/WhiteSur-gtk-theme
arch = any
license = GPL
- makedepends = dialog
makedepends = git
- makedepends = gtk-engine-murrine
- makedepends = imagemagick
- makedepends = libnotify
makedepends = sassc
optdepends = gtk-engine-murrine: GTK2 theme support
optdepends = gtk-engines: GTK2 theme support
@@ -26,4 +22,3 @@ pkgbase = whitesur-gtk-theme-git
sha256sums = SKIP
pkgname = whitesur-gtk-theme-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f876d5d4f299..a0d0efc3a493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=whitesur-gtk-theme-git
-pkgver=2021.05.05.r68.g474b0ec
+pkgver=2021.06.23.r87.gc790fa2
pkgrel=1
pkgdesc="MacOS Big Sur like theme for GNOME desktops"
arch=('any')
url="https://github.com/vinceliuice/WhiteSur-gtk-theme"
license=('GPL')
-makedepends=('dialog' 'git' 'gtk-engine-murrine' 'imagemagick' 'libnotify' 'sassc')
+makedepends=('git' 'sassc')
optdepends=('gtk-engine-murrine: GTK2 theme support'
'gtk-engines: GTK2 theme support'
'whitesur-icon-theme-git: matching icon theme'
@@ -22,25 +22,25 @@ source=("${pkgname%-git}::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/${pkgname%-git}"
- install -d "$pkgdir/usr/share/themes"
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/themes"
- # See for more customization options:
- # https://github.com/vinceliuice/WhiteSur-gtk-theme#theres-so-many-customizations-you-can-do
- ./install.sh \
- --alt all \
- --theme all \
- --dest "$pkgdir/usr/share/themes"
+ # See for more customization options:
+ # https://github.com/vinceliuice/WhiteSur-gtk-theme#theres-so-many-customizations-you-can-do
+ ./install.sh \
+ --alt all \
+ --theme all \
+ --dest "$pkgdir/usr/share/themes"
- install -Dm644 src/other/plank/theme-dark/* -t \
- "$pkgdir/usr/share/plank/themes/WhiteSur-dark"
- install -Dm644 src/other/plank/theme-light/* -t \
- "$pkgdir/usr/share/plank/themes/WhiteSur-light"
- install -d "$pkgdir/usr/share/docs/$pkgname"
- cp -r src/other/{dash-to-dock,firefox} "$pkgdir/usr/share/docs/$pkgname"
+ install -Dm644 src/other/plank/theme-dark/* -t \
+ "$pkgdir/usr/share/plank/themes/WhiteSur-dark"
+ install -Dm644 src/other/plank/theme-light/* -t \
+ "$pkgdir/usr/share/plank/themes/WhiteSur-light"
+ install -d "$pkgdir/usr/share/docs/$pkgname"
+ cp -r src/other/{dash-to-dock,firefox} "$pkgdir/usr/share/docs/$pkgname"
}