summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-24 10:23:48 -0600
committerMark Wagie2021-08-24 10:23:48 -0600
commit645ccb759bb455242cc260ebb48cf83171d52b4c (patch)
tree919c87e31664c36492bd335126e31c0ded3540e7
parent7164d6967e6c2c3d7fcfdcdbd06d2f88042a1a27 (diff)
downloadaur-645ccb759bb455242cc260ebb48cf83171d52b4c.tar.gz
PKBUILD improvements
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--whitesur-gtk-theme.install10
4 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44f3e595bc5b..e9d582e303b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = whitesur-gtk-theme-git
pkgdesc = MacOS Big Sur like theme for GNOME desktops
- pkgver = 2021.07.27.r0.gc790fa2
+ pkgver = 2021.07.27.r41.gd89e6e2
pkgrel = 1
url = https://github.com/vinceliuice/WhiteSur-gtk-theme
+ install = whitesur-gtk-theme.install
arch = any
license = GPL
makedepends = git
@@ -13,7 +14,6 @@ pkgbase = whitesur-gtk-theme-git
optdepends = whitesur-icon-theme-git: matching icon theme
optdepends = whitesur-cursor-theme-git: matching cursor theme
optdepends = whitesur-kvantum-theme: matching Kvantum theme
- optdepends = plank: for included plank theme
optdepends = gnome-shell-extension-dash-to-dock: recommended GNOME extension
optdepends = gnome-shell-extension-blur-my-shell: recommended GNOME extension
provides = whitesur-gtk-theme
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..6cc016aedf58 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!whitesur-gtk-theme.install
diff --git a/PKGBUILD b/PKGBUILD
index 860722b170c1..525bf5d5de6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=whitesur-gtk-theme-git
-pkgver=2021.07.27.r0.gc790fa2
+pkgver=2021.07.27.r41.gd89e6e2
pkgrel=1
pkgdesc="MacOS Big Sur like theme for GNOME desktops"
arch=('any')
@@ -12,11 +12,11 @@ optdepends=('gtk-engine-murrine: GTK2 theme support'
'whitesur-icon-theme-git: matching icon theme'
'whitesur-cursor-theme-git: matching cursor theme'
'whitesur-kvantum-theme: matching Kvantum theme'
- 'plank: for included plank theme'
'gnome-shell-extension-dash-to-dock: recommended GNOME extension'
'gnome-shell-extension-blur-my-shell: recommended GNOME extension')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+install="${pkgname%-git}.install"
options=('!strip')
source=("${pkgname%-git}::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git"
'wallpapers::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git#branch=wallpapers')
@@ -46,13 +46,17 @@ package() {
--theme all \
--dest "$pkgdir/usr/share/themes"
+ # Plank theme
install -Dm644 src/other/plank/theme-dark/* -t \
"$pkgdir/usr/share/plank/themes/WhiteSur-dark"
install -Dm644 src/other/plank/theme-light/* -t \
"$pkgdir/usr/share/plank/themes/WhiteSur-light"
+
+ # Firefox theme
install -d "$pkgdir/usr/share/docs/$pkgname"
- cp -r src/other/{dash-to-dock,firefox} "$pkgdir/usr/share/docs/$pkgname"
+ cp -r src/other/firefox "$pkgdir/usr/share/docs/$pkgname"
+ # Wallpapers
cd "$srcdir/wallpapers"
install -d "$pkgdir"/usr/share/{backgrounds,gnome-background-properties}
./install-gnome-backgrounds.sh
diff --git a/whitesur-gtk-theme.install b/whitesur-gtk-theme.install
new file mode 100644
index 000000000000..479af1da22e6
--- /dev/null
+++ b/whitesur-gtk-theme.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo ""
+ echo "Firefox theme"
+ echo "See /usr/share/doc/whitesur-gtk-theme/firefox/README.md"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}