summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-27 10:15:15 -0600
committerMark Wagie2021-07-27 10:15:15 -0600
commit7164d6967e6c2c3d7fcfdcdbd06d2f88042a1a27 (patch)
treea123ec9bcf8f359c9f1f614b58c19a0bf7d4073d
parent34b2d71844ca9b9c8f6492695c5eca777a475fa8 (diff)
downloadaur-7164d6967e6c2c3d7fcfdcdbd06d2f88042a1a27.tar.gz
add wallpapers
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a792fba98e4..44f3e595bc5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = whitesur-gtk-theme-git
pkgdesc = MacOS Big Sur like theme for GNOME desktops
- pkgver = 2021.06.23.r87.gc790fa2
+ pkgver = 2021.07.27.r0.gc790fa2
pkgrel = 1
url = https://github.com/vinceliuice/WhiteSur-gtk-theme
arch = any
license = GPL
makedepends = git
makedepends = sassc
+ makedepends = setconf
optdepends = gtk-engine-murrine: GTK2 theme support
optdepends = gtk-engines: GTK2 theme support
optdepends = whitesur-icon-theme-git: matching icon theme
@@ -19,6 +20,8 @@ pkgbase = whitesur-gtk-theme-git
conflicts = whitesur-gtk-theme
options = !strip
source = whitesur-gtk-theme::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git
+ source = wallpapers::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git#branch=wallpapers
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = whitesur-gtk-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index a0d0efc3a493..860722b170c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=whitesur-gtk-theme-git
-pkgver=2021.06.23.r87.gc790fa2
+pkgver=2021.07.27.r0.gc790fa2
pkgrel=1
pkgdesc="MacOS Big Sur like theme for GNOME desktops"
arch=('any')
url="https://github.com/vinceliuice/WhiteSur-gtk-theme"
license=('GPL')
-makedepends=('git' 'sassc')
+makedepends=('git' 'sassc' 'setconf')
optdepends=('gtk-engine-murrine: GTK2 theme support'
'gtk-engines: GTK2 theme support'
'whitesur-icon-theme-git: matching icon theme'
@@ -18,14 +18,23 @@ optdepends=('gtk-engine-murrine: GTK2 theme support'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('!strip')
-source=("${pkgname%-git}::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git")
-sha256sums=('SKIP')
+source=("${pkgname%-git}::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git"
+ 'wallpapers::git+https://github.com/vinceliuice/WhiteSur-gtk-theme.git#branch=wallpapers')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/wallpapers"
+ setconf install-gnome-backgrounds.sh BACKGROUND_DIR "$pkgdir/usr/share/backgrounds"
+ setconf install-gnome-backgrounds.sh PROPERTIES_DIR "$pkgdir/usr/share/gnome-background-properties"
+ setconf install-wallpapers.sh WALLPAPER_DIR "$pkgdir/usr/share/backgrounds"
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
install -d "$pkgdir/usr/share/themes"
@@ -43,4 +52,9 @@ package() {
"$pkgdir/usr/share/plank/themes/WhiteSur-light"
install -d "$pkgdir/usr/share/docs/$pkgname"
cp -r src/other/{dash-to-dock,firefox} "$pkgdir/usr/share/docs/$pkgname"
+
+ cd "$srcdir/wallpapers"
+ install -d "$pkgdir"/usr/share/{backgrounds,gnome-background-properties}
+ ./install-gnome-backgrounds.sh
+ ./install-wallpapers.sh
}