summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2021-10-25 20:23:55 +0800
committerKaizhao Zhang2021-10-25 20:29:19 +0800
commit98f42be1d39b9962233f40dfa89e0ccb4ed3fedc (patch)
tree210a2467e713e6a4c69a5ca719247f4148ee8e6f
downloadaur-98f42be1d39b9962233f40dfa89e0ccb4ed3fedc.tar.gz
Initial import with version 2021.10.13 (2021-10-13)
This is ported from whitesur-icon-theme-git package.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39467fb028d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = whitesur-icon-theme
+ pkgdesc = MacOS Big Sur like icon theme for linux desktops
+ pkgver = 2021.10.13
+ pkgrel = 1
+ url = https://github.com/vinceliuice/WhiteSur-icon-theme
+ arch = any
+ license = GPL3
+ optdepends = whitesur-gtk-theme: Recommended GTK theme
+ optdepends = whitesur-kde-theme: Recommended KDE theme
+ optdepends = whitesur-cursor-theme: Recommended cursor theme
+ conflicts = whitesur-icon-theme-git
+ options = !strip
+ source = WhiteSur-icon-theme-2021-10-13.tar.gz::https://github.com/vinceliuice/WhiteSur-icon-theme/archive/2021-10-13.tar.gz
+ sha256sums = 51b6f0f078036e85367c28d1da601449c66ccc202155c7d29726eca719cb0e39
+
+pkgname = whitesur-icon-theme
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..131e4c6cbc87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+# Contributor: Nico <d3sox at protonmail dot com>
+
+_pkgname=WhiteSur-icon-theme
+_pkgver=2021-10-13
+
+pkgname=whitesur-icon-theme
+pkgver="${_pkgver//-/.}"
+pkgrel=1
+pkgdesc="MacOS Big Sur like icon theme for linux desktops"
+arch=('any')
+optdepends=(
+ 'whitesur-gtk-theme: Recommended GTK theme'
+ 'whitesur-kde-theme: Recommended KDE theme'
+ 'whitesur-cursor-theme: Recommended cursor theme'
+)
+conflicts=("${pkgname}-git")
+license=('GPL3')
+url="https://github.com/vinceliuice/WhiteSur-icon-theme"
+options=('!strip')
+source=("${_pkgname}-${_pkgver}.tar.gz"::"${url}/archive/${_pkgver}.tar.gz")
+sha256sums=('51b6f0f078036e85367c28d1da601449c66ccc202155c7d29726eca719cb0e39')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
+ install -dm755 "${pkgdir}/usr/share/icons"
+ ./install.sh -d "${pkgdir}/usr/share/icons"
+}