summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3S0X2020-07-22 21:00:21 +0200
committerD3S0X2020-07-22 21:00:21 +0200
commit9f38805420b0f7624368ae94df19f851a7173cd3 (patch)
treea6ad7bfaaa9cce8f1a729dd458c34b64c4255d35
downloadaur-9f38805420b0f7624368ae94df19f851a7173cd3.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8d2dc3b08eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = whitesur-icon-theme-git
+ pkgdesc = MacOS Big Sur style icon theme for linux desktops
+ pkgver = 4.5fd57e6
+ pkgrel = 1
+ url = https://github.com/vinceliuice/WhiteSur-icon-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = gtk-update-icon-cache
+ optdepends = whitesur-gtk-theme-git: Recommended GTK theme
+ optdepends = whitesur-kde-theme-git: Recommended KDE theme
+ options = !strip
+ source = git+https://github.com/vinceliuice/WhiteSur-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = whitesur-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81e8b07f5dea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nico <desoxhd@gmail.com>
+pkgname=whitesur-icon-theme-git
+_gitname=WhiteSur-icon-theme
+pkgver=4.5fd57e6
+pkgrel=1
+pkgdesc="MacOS Big Sur style icon theme for linux desktops"
+arch=('any')
+makedepends=('git' 'gtk-update-icon-cache')
+optdepends=('whitesur-gtk-theme-git: Recommended GTK theme' 'whitesur-kde-theme-git: Recommended KDE theme')
+license=('GPL3')
+url="https://github.com/vinceliuice/${_gitname}"
+source=("git+${url}.git")
+sha256sums=('SKIP')
+options=('!strip')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -dm755 "${pkgdir}/usr/share/icons"
+ ./install.sh -d "${pkgdir}/usr/share/icons"
+}