summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-22 04:12:38 -0700
committerMark Wagie2021-01-22 04:12:38 -0700
commit6c2b276305d2b31f10dd69ab32d7ffc3e09d610f (patch)
treec6ab5da8af85b66563effbfbc32291defdea237d
parentaab9ca3c385fcac89e55f756ac6cff564095d6d9 (diff)
downloadaur-6c2b276305d2b31f10dd69ab32d7ffc3e09d610f.tar.gz
adjustments
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be337dc6bfff..086875859684 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = whitesur-kvantum-theme-git
- pkgdesc = MacOS big sur like theme for KDE Plasma
- pkgver = r23.f8277d2
+ pkgdesc = WhiteSur theme for Kvantum
+ pkgver = r33.a7f777c
pkgrel = 1
url = https://github.com/vinceliuice/WhiteSur-kde
arch = any
license = GPL3
makedepends = git
depends = kvantum-qt5
- optdepends = whitesur-icon-theme-git: matching icon theme
- optdepends = whitesur-cursor-theme-git: matching cursor theme
- optdepends = whitesur-gtk-theme-git: matching gtk theme
+ provides = whitesur-kvantum-theme
+ conflicts = whitesur-kvantum-theme
conflicts = whitesur-kde-theme-git
source = git+https://github.com/vinceliuice/WhiteSur-kde.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 77855b515ba7..94133b4d1470 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
-# Maintainer: Nico <desoxhd@gmail.com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: librewish
pkgname=whitesur-kvantum-theme-git
-_themeName=WhiteSur
-_gitname="$_themeName-kde"
-pkgver=r23.f8277d2
+_gitname=WhiteSur-kde
+pkgver=r33.a7f777c
pkgrel=1
-pkgdesc="MacOS big sur like theme for KDE Plasma"
+pkgdesc="WhiteSur theme for Kvantum"
arch=('any')
-url="https://github.com/vinceliuice/${_gitname}"
+url="https://github.com/vinceliuice/WhiteSur-kde"
license=('GPL3')
depends=('kvantum-qt5')
-optdepends=( 'whitesur-icon-theme-git: matching icon theme' 'whitesur-cursor-theme-git: matching cursor theme' 'whitesur-gtk-theme-git: matching gtk theme' )
makedepends=('git')
-source=("git+${url}.git")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'whitesur-kde-theme-git')
+source=('git+https://github.com/vinceliuice/WhiteSur-kde.git')
sha256sums=('SKIP')
-conflicts=('whitesur-kde-theme-git')
pkgver() {
- cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- # make folders
- mkdir -p "${pkgdir}/usr/share/Kvantum"
- # kvantum theme
- cp -r "${srcdir}/${_gitname}/Kvantum"/* "${pkgdir}/usr/share/Kvantum"
-
-}
+ cd "$srcdir/$_gitname"
+ install -d "$pkgdir/usr/share"
+ cp -r Kvantum "$pkgdir/usr/share"
+}