summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-25 16:35:26 +0800
committerChocobo12017-08-25 17:35:56 +0800
commit3c75b4b3fa4f0a2ad580d9619bcb9980e6c4b747 (patch)
treea268aae5bbfb8418ba580ebe2d5703f5bdaddad2
downloadaur-3c75b4b3fa4f0a2ad580d9619bcb9980e6c4b747.tar.gz
newpkg: whois-git 5.2.18.r0.g5dd942b-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deabde5e7c08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = whois-git
+ pkgdesc = Provides useful functions commonly found on BSD systems
+ pkgver = 5.2.18.r0.g5dd942b
+ pkgrel = 1
+ url = https://github.com/rfc1036/whois
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = perl
+ depends = glibc
+ depends = libidn2
+ provides = whois
+ conflicts = whois
+ backup = etc/whois.conf
+ source = git+https://github.com/rfc1036/whois.git#branch=next
+ sha256sums = SKIP
+
+pkgname = whois-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e944b724b05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=whois-git
+pkgver=5.2.18.r0.g5dd942b
+pkgrel=1
+pkgdesc="Provides useful functions commonly found on BSD systems"
+arch=('i686' 'x86_64')
+url="https://github.com/rfc1036/whois"
+license=('GPL2')
+depends=('glibc' 'libidn2')
+makedepends=('git' 'perl')
+provides=('whois')
+conflicts=('whois')
+backup=('etc/whois.conf')
+source=("git+https://github.com/rfc1036/whois.git#branch=next")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "whois"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "whois"
+
+ make CFLAGS="$CFLAGS $CPPFLAGS" prefix="/usr" \
+ CONFIG_FILE=/etc/whois.conf \
+ LOCALEDIR=1 \
+ HAVE_LIBIDN=1 HAVE_ICONV=1
+}
+
+package() {
+ cd "whois"
+
+ make BASEDIR="$pkgdir" prefix="/usr" install-whois install-pos
+ install -Dm644 "whois.conf" "$pkgdir/etc/whois.conf"
+}