summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-04-12 18:40:14 +0800
committerwenLiangcan2016-04-12 18:40:14 +0800
commitfa9ef3c668ff49395e207426f529fbbd9873b7e6 (patch)
tree461558705f33d1636da5630f2486050075ed54b4
downloadaur-fa9ef3c668ff49395e207426f529fbbd9873b7e6.tar.gz
whoneeds-git r5.1593694-1.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD26
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75dec4dd0b02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Apr 12 10:39:17 UTC 2016
+pkgbase = whoneeds-git
+ pkgdesc = A fast whoneeds implemention in Python for Arch Linux
+ pkgver = r5.1593694
+ pkgrel = 1
+ url = https://gist.github.com/lilydjwg/69111965e237fdb67d1378703173709f
+ arch = any
+ license = unkown
+ depends = python
+ depends = pyalpm
+ provides = whoneeds
+ conflicts = whoneeds
+ source = whoneeds::git+https://gist.github.com/69111965e237fdb67d1378703173709f.git
+ md5sums = SKIP
+
+pkgname = whoneeds-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2dfda3a1878f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+### https://raw.github.com/github/gitignore/fa441f903154d8159ef71db23d4816d802450fef/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+whoneeds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3192ae96a6dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+_pkgname=whoneeds
+pkgname=${_pkgname}-git
+pkgver=r5.1593694
+pkgrel=1
+pkgdesc="A fast whoneeds implemention in Python for Arch Linux"
+arch=('any')
+url="https://gist.github.com/lilydjwg/69111965e237fdb67d1378703173709f"
+license=('unkown')
+depends=('python' 'pyalpm')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${_pkgname}"::'git+https://gist.github.com/69111965e237fdb67d1378703173709f.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}
+