summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 12:09:34 +0200
committerMartin Doege2015-06-09 12:09:34 +0200
commit8d1ee7597a5eb0475da63add442546343783e3cf (patch)
treea6a765e46c1ba6eb744f22b27ffb701b495b3df3
downloadaur-8d1ee7597a5eb0475da63add442546343783e3cf.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df61830d4ea7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = whysynth
+ pkgdesc = A versatile softsynth plugin for the DSSI Soft Synth Interface
+ pkgver = 20120903
+ pkgrel = 2
+ url = http://www.smbolton.com/whysynth.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = dssi
+ depends = alsa-lib
+ depends = liblo
+ depends = gtk2
+ depends = fftw
+ source = http://www.smbolton.com/whysynth/whysynth-20120903.tar.bz2
+ md5sums = b521b63ade13b09062a64c46d2eabee2
+
+pkgname = whysynth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28ce925f8b2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sean Bolton <sean at smbolton dot com>
+pkgname=whysynth
+pkgver=20120903
+pkgrel=2
+pkgdesc="A versatile softsynth plugin for the DSSI Soft Synth Interface"
+url="http://www.smbolton.com/whysynth.html"
+depends=('alsa-lib' 'liblo' 'gtk2' 'fftw')
+makedepends=('dssi')
+license=('GPL')
+source=(http://www.smbolton.com/whysynth/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('b521b63ade13b09062a64c46d2eabee2')
+arch=('i686' 'x86_64')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR=${pkgdir} install || return 1
+ find ${pkgdir}/usr/lib -name '*.la' -exec rm {} \; || return 1
+}