summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2015-12-15 17:52:48 +0300
committerAlex Talker2015-12-15 17:52:48 +0300
commitb906cb155e4503628cebc02b05c7e1252d6d65f5 (patch)
tree045a51aa7d759fe32f87af85e52605ec51c4b3a6
downloadaur-b906cb155e4503628cebc02b05c7e1252d6d65f5.tar.gz
Inital commit.
-rw-r--r--.SRCINFO56
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD85
-rw-r--r--curses_bitrate_fix.patch19
-rw-r--r--wicd-1.7.3-urwid-1.3.0.patch15
-rw-r--r--wicd-1421918.patch16
-rw-r--r--wicd.install19
7 files changed, 214 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c13829e62a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,56 @@
+pkgbase = wicd
+ pkgdesc = Wired and wireless network manager for Linux. Include patches that fix wicd-curses bugs.
+ pkgver = 1.7.3
+ pkgrel = 1
+ url = https://launchpad.net/wicd/
+ install = wicd.install
+ arch = any
+ license = GPL2
+ makedepends = python2
+ makedepends = python2-babel
+ makedepends = python2-setuptools
+ makedepends = gettext
+ makedepends = dbus-glib
+ makedepends = dhcpcd
+ makedepends = ethtool
+ makedepends = inetutils
+ makedepends = net-tools
+ makedepends = python2-dbus
+ makedepends = python2-gobject2
+ makedepends = python2-urwid
+ makedepends = rfkill
+ makedepends = shared-mime-info
+ makedepends = wireless_tools
+ makedepends = wpa_supplicant
+ makedepends = hicolor-icon-theme
+ depends = python2
+ depends = python2-dbus
+ depends = dhcpcd
+ depends = wpa_supplicant
+ depends = wireless_tools
+ depends = inetutils
+ depends = net-tools
+ depends = ethtool
+ depends = shared-mime-info
+ depends = python2-urwid
+ depends = python2-gobject2
+ depends = dbus-glib
+ depends = rfkill
+ optdepends = wicd-gtk: needed if you want the GTK interface
+ provides = wicd
+ conflicts = wicd
+ conflicts = wicd-svn
+ replaces = wicd
+ options = emptydirs
+ backup = etc/wicd/encryption/templates/active
+ source = http://launchpad.net/wicd/1.7/1.7.3/+download/wicd-1.7.3.tar.gz
+ source = wicd-1.7.3-urwid-1.3.0.patch
+ source = wicd-1421918.patch
+ source = curses_bitrate_fix.patch
+ md5sums = 162ca2e6f4ab903bb7ab2bc0adb7d1aa
+ md5sums = f7e6085e482f37f2b8529326c21cbbbf
+ md5sums = d1568f48d63103df962b5b502d0ad0de
+ md5sums = a907075f648a0e8d91c0ce6898e973b5
+
+pkgname = wicd-patched
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e7296de49a7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/*
+src/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..833b2dde92de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# $Id: PKGBUILD 230411 2015-02-04 01:50:30Z angvp $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Rashif "Don Ray" Rahman <rayrashif@gmail.com>
+
+pkgbase='wicd'
+pkgname='wicd-patched'
+pkgver=1.7.3
+pkgrel=1
+arch=(any)
+url="https://launchpad.net/wicd/"
+license=('GPL2')
+provides=('wicd')
+replaces=('wicd')
+conflicts=('wicd' 'wicd-svn')
+pkgdesc="Wired and wireless network manager for Linux. Include patches that fix wicd-curses bugs."
+depends=('python2' 'python2-dbus' 'dhcpcd' 'wpa_supplicant' 'wireless_tools'
+ 'inetutils' 'net-tools' 'ethtool' 'shared-mime-info' 'python2-urwid' 'python2-gobject2' 'dbus-glib' 'rfkill')
+optdepends=('wicd-gtk: needed if you want the GTK interface')
+backup=('etc/wicd/encryption/templates/active')
+install=wicd.install
+
+source=(http://launchpad.net/wicd/1.7/$pkgver/+download/wicd-$pkgver.tar.gz
+ wicd-1.7.3-urwid-1.3.0.patch
+ wicd-1421918.patch
+ curses_bitrate_fix.patch)
+md5sums=('162ca2e6f4ab903bb7ab2bc0adb7d1aa'
+ 'f7e6085e482f37f2b8529326c21cbbbf'
+ 'd1568f48d63103df962b5b502d0ad0de'
+ 'a907075f648a0e8d91c0ce6898e973b5')
+makedepends=('python2' 'python2-babel' 'python2-setuptools' 'gettext' 'dbus-glib' 'dhcpcd'
+ 'ethtool' 'inetutils' 'net-tools' 'python2-dbus' 'python2-gobject2'
+ 'python2-urwid' 'rfkill' 'shared-mime-info' 'wireless_tools' 'wpa_supplicant'
+ 'hicolor-icon-theme')
+options=('emptydirs')
+
+prepare() {
+ cd $pkgbase-$pkgver
+
+ find . -type f -exec sed -i 's@#!/usr.*python@#!/usr/bin/python2@' {} \;
+ sed -i 's/pybabel/pybabel2/g' setup.py
+ export PYTHON=python2
+
+ sed -i 's|/usr/sbin/|/usr/bin/|' other/wicd.service
+ patch -Np0 -i "$srcdir/wicd-1.7.3-urwid-1.3.0.patch"
+ patch -Np0 -i "$srcdir/wicd-1421918.patch"
+ patch -Np0 -i "$srcdir/curses_bitrate_fix.patch"
+}
+
+build() {
+ cd $pkgbase-$pkgver
+ python2 setup.py configure \
+ --no-install-init \
+ --resume=/usr/share/wicd/scripts/ \
+ --suspend=/usr/share/wicd/scripts/ \
+ --verbose \
+ --python=/usr/bin/python2 \
+ --lib=/usr/lib \
+ --sbin=/usr/bin \
+ --no-install-gnome-shell-extensions \
+ --systemd=/usr/lib/systemd/system
+ python2 setup.py build
+ python2 setup.py compile_translations
+
+ #HACK for https://bugs.launchpad.net/wicd/+bug/928589
+ mkdir -p translations/ast/LC_MESSAGES
+ msgfmt po/ast.po -o translations/ast/LC_MESSAGES/wicd.mo
+}
+
+package() {
+ cd $pkgbase-$pkgver
+ python2 setup.py install --skip-build --optimize=1 --root="$pkgdir"
+
+ cd build/lib/wicd
+ for i in *.py; do
+ install -Dm 755 $i "$pkgdir/usr/lib/wicd/$i"
+ done
+
+ rm -rf "$pkgdir"/usr/share/autostart
+
+ #deleting the GTK stuff
+ rm -rf "$pkgdir"/etc/xdg
+ rm -f "$pkgdir"/usr/bin/{wicd-client,wicd-gtk}
+ rm -rf "$pkgdir"/usr/share/{applications,icons,pixmaps}
+ rm -rf "$pkgdir"/usr/share/wicd/{gtk,icons}
+}
diff --git a/curses_bitrate_fix.patch b/curses_bitrate_fix.patch
new file mode 100644
index 000000000000..6ac3902fe548
--- /dev/null
+++ b/curses_bitrate_fix.patch
@@ -0,0 +1,19 @@
+--- curses/netentry_curses.py 2015-02-15 18:29:05.000000000 +0100
++++ curses/netentry_curses.py 2015-02-15 18:31:24.000000000 +0100
+@@ -538,11 +538,12 @@
+ self.bitrates = wireless.GetAvailableBitrates()
+ self.bitrates.append('auto')
+ self.bitrate_combo.set_list(self.bitrates)
+- self.bitrate_combo.set_focus(
+- self.bitrates.index(
+- wireless.GetWirelessProperty(networkID, 'bitrate')
++ if wireless.GetWirelessProperty(networkID, 'bitrate'):
++ self.bitrate_combo.set_focus(
++ self.bitrates.index(
++ wireless.GetWirelessProperty(networkID, 'bitrate')
++ )
+ )
+- )
+ self.allow_lower_bitrates_chkbox.set_state(
+ to_bool(self.format_entry(networkID, 'allow_lower_bitrates'))
+ )
diff --git a/wicd-1.7.3-urwid-1.3.0.patch b/wicd-1.7.3-urwid-1.3.0.patch
new file mode 100644
index 000000000000..a028059f5615
--- /dev/null
+++ b/wicd-1.7.3-urwid-1.3.0.patch
@@ -0,0 +1,15 @@
+--- curses/wicd-curses.py 2015-01-27 22:35:25.414781192 -0300
++++ cursesb/wicd-curses.py 2015-01-28 01:13:48.078904587 -0300
+@@ -1153,9 +1153,10 @@
+ if not ui._started:
+ return False
+
+- input_data = ui.get_input_nonblocking()
++ ui.set_input_timeouts(max_wait=0)
++ input_data = ui.get_input()
+ # Resolve any "alarms" in the waiting
+- self.handle_keys(input_data[1])
++ self.handle_keys(input_data)
+
+ # Update the screen
+ canvas = self.frame.render((self.size), True)
diff --git a/wicd-1421918.patch b/wicd-1421918.patch
new file mode 100644
index 000000000000..f855ec5b1cc3
--- /dev/null
+++ b/wicd-1421918.patch
@@ -0,0 +1,16 @@
+=== modified file 'curses/wicd-curses.py'
+--- curses/wicd-curses.py 2014-12-21 16:57:33 +0000
++++ curses/wicd-curses.py 2015-02-24 23:41:01 +0000
+@@ -532,7 +532,10 @@
+ def get_selected_profile(self):
+ """Get the selected wired profile"""
+ loc = self.get_focus()[1]
+- return self.theList[loc]
++ if len(self.theList) > loc:
++ return self.theList[loc]
++ else:
++ return self.theList[-1]
+
+
+ class AdHocDialog(Dialog2):
+
diff --git a/wicd.install b/wicd.install
new file mode 100644
index 000000000000..6bb3d3ae113b
--- /dev/null
+++ b/wicd.install
@@ -0,0 +1,19 @@
+PKGNAME=wicd
+
+pre_remove () {
+ for pyo in $(pacman -Qql $PKGNAME | grep \.py$ | sed 's|.py$|.pyo|g'); do
+ if [ -f "$pyo" ]; then
+ rm "$pyo"
+ fi
+ done
+}
+
+post_install() {
+ echo
+ echo "==> You need to restart the dbus service after "
+ echo "==> upgrading wicd."
+ echo "==> Disable networkmanager, dhcpcd or other networking "
+ echo "==> utility and add 'wicd' to your systemd configuration."
+ echo
+ echo "==> To run: wicd-cli or wicd-curses"
+}