summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2016-03-10 18:20:47 +0100
committeractionless2016-03-10 18:21:14 +0100
commit58b1b227e2b5a0ca949a052a6018d862e0eee331 (patch)
tree2c23d4509820268a829d03c9b26a0c959627f094
parentceaa447a10c80f52de2db0756dc5de4b112f9e9d (diff)
downloadaur-58b1b227e2b5a0ca949a052a6018d862e0eee331.tar.gz
show warning instead of renaming executable
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--wickr-bin.install11
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cf6b57aba58..788fdb08ed7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = wickr-bin
pkgdesc = Wickr messenger
pkgver = 2.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://wickr.com
+ install = wickr-bin.install
arch = x86_64
license = Proprietary
depends = libutil-linux
@@ -49,7 +50,9 @@ pkgbase = wickr-bin
depends = libx264
options = !strip
source = https://dls.wickr.com/Downloads/wickr-me_2.6.0_amd64.deb
+ source = wickr-bin.install
md5sums = 5bc94a9634f25630d5171d056e0fa137
+ md5sums = ab8afb848c5382aba9a9b6c828e56c1b
pkgname = wickr-bin
diff --git a/PKGBUILD b/PKGBUILD
index 04b063dec204..98e243c78e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wickr-bin
pkgver=2.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Wickr messenger"
PKGEXT='.pkg.tar'
arch=('x86_64')
@@ -17,13 +17,19 @@ depends=( 'libutil-linux' 'glibc' 'gcc-libs' 'glib2' 'zlib' 'lz4' 'xz'
'libxext' 'libxdamage' 'libxfixes' 'libxshmfence' 'libxxf86vm' 'libasyncns'
'orc' 'libxau' 'libxdmcp' 'libcap' 'libgcrypt' 'libgpg-error' 'attr' 'libx264')
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
-source=("https://dls.wickr.com/Downloads/wickr-me_${pkgver}_amd64.deb")
-md5sums=('5bc94a9634f25630d5171d056e0fa137')
+source=(
+ "https://dls.wickr.com/Downloads/wickr-me_${pkgver}_amd64.deb"
+ "wickr-bin.install"
+)
+md5sums=(
+ "5bc94a9634f25630d5171d056e0fa137"
+ "ab8afb848c5382aba9a9b6c828e56c1b"
+)
+install="wickr-bin.install"
package() {
- bsdtar xf data.tar.xz
- chmod -R g-w usr
- mv usr "${pkgdir}"
+ bsdtar xf data.tar.xz
+ chmod -R g-w usr
+ mv usr "${pkgdir}"
- ln -s /usr/lib/libx264.so ${pkgdir}/usr/lib/libx264.so.142
- mv ${pkgdir}/usr/bin/wickr-me ${pkgdir}/usr/bin/wickr
+ ln -s /usr/lib/libx264.so ${pkgdir}/usr/lib/libx264.so.142
}
diff --git a/wickr-bin.install b/wickr-bin.install
new file mode 100644
index 000000000000..d5e42b21eef5
--- /dev/null
+++ b/wickr-bin.install
@@ -0,0 +1,11 @@
+notify() {
+ echo -e "\e[31m\e[1mExecutable was renamed to 'wickr-me'"
+}
+
+post_install() {
+ notify
+}
+
+post_upgrade() {
+ notify
+}