summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2023-04-13 22:06:07 +0200
committerdreieck2023-04-13 22:06:07 +0200
commit367c74cb1e82c2f6a52551e1f2725c2a768a64dc (patch)
tree6c8ea582eddc730c3e73c23eaceef551078dfbcb
downloadaur-367c74cb1e82c2f6a52551e1f2725c2a768a64dc.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f531c846f9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = widelands-maps-rttr
+ pkgdesc = Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands.
+ pkgver = a
+ pkgrel = 1
+ url = http://siedler25.org/
+ arch = any
+ license = GPL2
+ makedepends = return-to-the-roots
+ depends = return-to-the-roots
+ optdepends = widelands: To play the maps with widelands.
+ replaces = widelands-maps-rttr-localver
+ options = emptydirs
+
+pkgname = widelands-maps-rttr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e61965852276
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: dreieck
+
+_pkgname="widelands-maps-rttr"
+pkgname="${_pkgname}"
+pkgdesc="Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands."
+url='http://siedler25.org/'
+arch=('any')
+pkgver=a
+pkgrel=1
+depends=('return-to-the-roots')
+makedepends=('return-to-the-roots') # Needed for pkgver()
+optdepends=('widelands: To play the maps with widelands.')
+provides=()
+conflicts=()
+replaces=("${_pkgname}-localver")
+license=('GPL2')
+options+=('emptydirs')
+source=()
+sha256sums=()
+
+pkgver() {
+ # Set the pkgver to that of the installed return-to-the-root.
+ pacman -Q return-to-the-roots | awk '{print $2}' | sed 's|-.*||'
+}
+
+package() {
+ install -d -v -m755 "${pkgdir}/usr/share/widelands/maps"
+ ln -svr "${pkgdir}/usr/share/s25rttr/RTTR/MAPS" "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
+}