summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-09-19 15:43:17 +0200
committerfelics2018-09-19 15:43:17 +0200
commite6b723b50dbd6e902b3fca8994e0199e6b7e49c0 (patch)
tree7a3768797e8527ccf7ce30f8e587c0c917a31b9b
downloadaur-e6b723b50dbd6e902b3fca8994e0199e6b7e49c0.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8efa5505b465
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = widelands-maps-rttr-localver
+ pkgdesc = Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands.
+ pkgver = r3946.826300c2
+ pkgrel = 3
+ url = http://siedler25.org/
+ arch = any
+ license = GPL2
+ makedepends = return-to-the-roots
+ depends = return-to-the-roots
+ optdepends = widelands: To play the maps with widelands.
+ provides = widelands-maps-rttr=r3946.826300c2
+ conflicts = widelands-maps-rttr
+ options = emptydirs
+
+pkgname = widelands-maps-rttr-localver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf1126ad4ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: dreieck
+
+_pkgname="widelands-maps-rttr"
+pkgname="${_pkgname}-localver"
+pkgdesc="Makes the maps installed by the Settlers II-remake 'Return to the Roots' available to play with widelands."
+url='http://siedler25.org/'
+arch=('any')
+pkgver=r3946.826300c2
+pkgrel=3
+depends=('return-to-the-roots')
+makedepends=('return-to-the-roots') # Needed for pkgver()
+optdepends=('widelands: To play the maps with widelands.')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+license=('GPL2')
+options+=('emptydirs')
+source=()
+sha256sums=()
+
+pkgver() {
+ # Set the pkgver to that of the installed return-to-the-root.
+ pacman -Qi return-to-the-roots | grep -E '^Version' | head -n 1 | awk -F ':' '{print $2}' | awk -F '-' '{print $1}' | tr -d '[[:space:]]'
+}
+
+package() {
+ install -v -m755 -d "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
+ cd "${pkgdir}/usr/share/widelands/maps/Return to the Roots-maps"
+ ln -sv "/usr/share/s25rttr/RTTR/MAPS/NEW" "Newer maps"
+ ln -sv "/usr/share/s25rttr/RTTR/MAPS/OTHER" "Other maps"
+ ln -sv "/usr/share/s25rttr/RTTR/MAPS/SEA" "Seafearing maps"
+}