summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2023-02-22 16:47:17 +0100
committerBart De Vries2023-02-22 22:32:30 +0100
commitcc023fc37df57dc594d42eb15d1aa8dff418a489 (patch)
treebd79e447b785036f88f664df14714333f185c5bd
parent43afc03f7fabea3ae1eab77c23539a71bc2c846b (diff)
downloadaur-cc023fc37df57dc594d42eb15d1aa8dff418a489.tar.gz
Update to 4.10.2257.0
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD10
-rw-r--r--ldadd_swp.c13
4 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be2608b51293..af46f9de813d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = widevine-armv7h
pkgdesc = A browser plugin designed for the viewing of premium video content (version for armv7h)
- pkgver = 4.10.2252.0
+ pkgver = 4.10.2257.0
pkgrel = 1
url = https://www.widevine.com/
install = widevine-armv7h.install
@@ -16,12 +16,12 @@ pkgbase = widevine-armv7h
conflicts = chromium-widevine-armv7h
options = !strip
source = chrome-eula_text.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html
- source = https://archive.raspberrypi.org/debian/pool/main/w/widevine/libwidevinecdm0_4.10.2252.0-1_armhf.deb
+ source = https://archive.raspberrypi.org/debian/pool/main/w/widevine/libwidevinecdm0_4.10.2252.0+1_armhf.deb
source = register_widevine_chromium
source = register_widevine_firefox
source = widevine-armv7h.install
sha256sums = SKIP
- sha256sums = 47703a2db5aacb8ec77318041c4327645a6b81a78839857357edbcb9275f05ef
+ sha256sums = f4d35cfdfc046450f28b30114066dda1d7f2fb1f174219da4610c048e31175c6
sha256sums = ebca260ca197c4eee5a8b76ae1fad2bf800ab99b40d8be0c2189b566bd9621d0
sha256sums = b976bb594b8b51d5eee1929defaebd0313c54ddd6d62241bfa4a7d5421491e12
sha256sums = 6be10c8786b24f47dbbb54ff676f28a7b49771b8d5f7c03cc3f2e73b7e18c22f
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index e711887a6147..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,8 +0,0 @@
-Google LLC and its affiliates ("Google") own all legal right, title and
-interest in and to the content decryption module software ("Software") and
-related documentation, including any intellectual property rights in the
-Software. You may not use, modify, sell, or otherwise distribute the Software
-without a separate license agreement with Google. The Software is not open
-source software.
-
-If you are interested in licensing the Software, please contact www.widevine.com
diff --git a/PKGBUILD b/PKGBUILD
index dc8a4cac2725..47eb1024cf36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
pkgname=widevine-armv7h
pkgdesc='A browser plugin designed for the viewing of premium video content (version for armv7h)'
-pkgver=4.10.2252.0
+pkgver=4.10.2257.0
_debian_pkgname='libwidevinecdm0'
-_debian_pkgrel=1
+_debian_pkgver=4.10.2252.0
+_debian_pkgrel=+1
pkgrel=1
arch=('armv7h')
url='https://www.widevine.com/'
@@ -15,17 +16,16 @@ conflicts=('chromium-widevine' 'chromium-widevine-armv7h')
install="widevine-armv7h.install"
options=('!strip')
source=("chrome-eula_text.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html"
- "https://archive.raspberrypi.org/debian/pool/main/w/widevine/${_debian_pkgname}_${pkgver}-${_debian_pkgrel}_armhf.deb"
+ "https://archive.raspberrypi.org/debian/pool/main/w/widevine/${_debian_pkgname}_${_debian_pkgver}${_debian_pkgrel}_armhf.deb"
"register_widevine_chromium"
"register_widevine_firefox"
"widevine-armv7h.install")
sha256sums=(SKIP
- '47703a2db5aacb8ec77318041c4327645a6b81a78839857357edbcb9275f05ef'
+ 'f4d35cfdfc046450f28b30114066dda1d7f2fb1f174219da4610c048e31175c6'
'ebca260ca197c4eee5a8b76ae1fad2bf800ab99b40d8be0c2189b566bd9621d0'
'b976bb594b8b51d5eee1929defaebd0313c54ddd6d62241bfa4a7d5421491e12'
'6be10c8786b24f47dbbb54ff676f28a7b49771b8d5f7c03cc3f2e73b7e18c22f')
-
prepare() {
# Extract data.tar.gz from deb package
tar -xf data.tar.xz
diff --git a/ldadd_swp.c b/ldadd_swp.c
new file mode 100644
index 000000000000..d664837d0d8d
--- /dev/null
+++ b/ldadd_swp.c
@@ -0,0 +1,13 @@
+#include <stdint.h>
+
+__attribute__((target("no-outline-atomics")))
+int32_t __aarch64_ldadd4_acq_rel(int32_t value, int32_t *ptr)
+{
+ return __atomic_fetch_add(ptr, value, __ATOMIC_ACQ_REL);
+}
+
+__attribute__((target("no-outline-atomics")))
+int32_t __aarch64_swp4_acq_rel(int32_t value, int32_t *ptr)
+{
+ return __atomic_exchange_n(ptr, value, __ATOMIC_ACQ_REL);
+}