summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-17 21:56:36 -0500
committerLuis Martinez2021-05-17 21:56:36 -0500
commit08cf70be509053ddbcfbac667fb7df55927fef33 (patch)
tree98d855c6552aa1b1e51603b9e6e221fb68a4fe51
downloadaur-08cf70be509053ddbcfbac667fb7df55927fef33.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf4b6f280a5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wifi-heat-mapper
+ pkgdesc = A Python library for benchmarking Wi-Fi networks to create heatmaps
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/nischay-pro/wifi-heat-mapper
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-iperf3
+ depends = python-matplotlib
+ depends = python-tqdm
+ depends = python-pillow
+ depends = python-scipy
+ depends = python-numpy
+ depends = python-pysimplegui
+ optdepends = speedtest-cli
+ source = https://files.pythonhosted.org/packages/source/w/whm/whm-0.2.2.tar.gz
+ sha256sums = fbf752a5b37695618126715d67b0c4228c137d10a17eb40594894bd0c67532da
+
+pkgname = wifi-heat-mapper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3edde2dcbb3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=wifi-heat-mapper
+_name=whm
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="A Python library for benchmarking Wi-Fi networks to create heatmaps"
+arch=('x86_64')
+url="https://github.com/nischay-pro/wifi-heat-mapper"
+license=('GPL3')
+depends=('python' 'python-iperf3' 'python-matplotlib' 'python-tqdm'
+ 'python-pillow' 'python-scipy' 'python-numpy' 'python-pysimplegui')
+makedepends=('python-setuptools')
+optdepends=('speedtest-cli')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('fbf752a5b37695618126715d67b0c4228c137d10a17eb40594894bd0c67532da')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}