summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiobolic2021-01-28 10:06:47 -0500
committerDiobolic2021-01-28 10:06:47 -0500
commit91c097c4301989791d3644d7f97d83755281d482 (patch)
tree8f13299a0a8fdb2081038f59784db751c4f99d3f
parent0f275e5c16aa085440ea94f5b5632099b065c15f (diff)
downloadaur-91c097c4301989791d3644d7f97d83755281d482.tar.gz
Added qrcode dependancy and MIT License
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f0d4ac46157..a1b933b5e44a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,14 +4,16 @@ pkgbase = wifi-password
pkgrel = 1
url = https://github.com/sdushantha/wifi-password
arch = any
- license = unknown
+ license = MIT
makedepends = python-setuptools
depends = python
depends = wireless_tools
+ depends = python-qrcode
source = https://files.pythonhosted.org/packages/source/w/wifi-password/wifi-password-1.0.3.tar.gz
sha256sums = 55aba4acb84cf35231e629b8440fd9e17bf3ceefd0cba64c8580855070ed8456
pkgname = wifi-password
depends = python
depends = wireless_tools
+ depends = python-qrcode
diff --git a/PKGBUILD b/PKGBUILD
index 3735fa9db370..1e9598ac087a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@ pkgver='1.0.3'
pkgrel=1
pkgdesc="Quickly fetch your WiFi password and if needed, generate a QR code of your WiFi to allow phones to easily connect"
url="https://github.com/sdushantha/wifi-password"
-depends=('python' 'wireless_tools')
+depends=('python' 'wireless_tools' 'python-qrcode')
makedepends=('python-setuptools')
-license=('unknown')
+license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
sha256sums=('55aba4acb84cf35231e629b8440fd9e17bf3ceefd0cba64c8580855070ed8456')
@@ -21,6 +21,7 @@ build() {
package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}