summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiobolic2021-01-27 15:32:26 -0500
committerDiobolic2021-01-27 15:32:26 -0500
commitf6480951abc0b683dcac630e2d1dfac8f285fdd7 (patch)
tree8b6fd493e016b1de6761e6931beb240bd455bd79
downloadaur-f6480951abc0b683dcac630e2d1dfac8f285fdd7.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f0d4ac46157
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wifi-password
+ pkgdesc = Quickly fetch your WiFi password and if needed, generate a QR code of your WiFi to allow phones to easily connect
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/sdushantha/wifi-password
+ arch = any
+ license = unknown
+ makedepends = python-setuptools
+ depends = python
+ depends = wireless_tools
+ source = https://files.pythonhosted.org/packages/source/w/wifi-password/wifi-password-1.0.3.tar.gz
+ sha256sums = 55aba4acb84cf35231e629b8440fd9e17bf3ceefd0cba64c8580855070ed8456
+
+pkgname = wifi-password
+ depends = python
+ depends = wireless_tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e0c05489b10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: Dakota marshalldakota549@pm.me
+
+pkgname=('wifi-password')
+_module='wifi-password'
+pkgver='1.0.3'
+pkgrel=1
+pkgdesc="Quickly fetch your WiFi password and if needed, generate a QR code of your WiFi to allow phones to easily connect"
+url="https://github.com/sdushantha/wifi-password"
+depends=('python' 'wireless_tools')
+makedepends=('python-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('55aba4acb84cf35231e629b8440fd9e17bf3ceefd0cba64c8580855070ed8456')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ sudo python setup.py install --optimize=1 --skip-build
+}