summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrpheas van Rooij2022-07-10 09:42:28 -0700
committerOrpheas van Rooij2022-07-10 09:42:28 -0700
commita18f38d838ae4c4e0a2ea600557857aa089d0a07 (patch)
treebcf58ececc571273e834b64aef480768491e5e5e
parent65d351166536cd5202bc11e901a0e78adad01ff4 (diff)
downloadaur-a18f38d838ae4c4e0a2ea600557857aa089d0a07.tar.gz
unpack Debian changelog archive
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0a9c64cb229..e0bd88345edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ arch=('x86_64')
url="https://www.github.com/kokoye2007/wifi-qr"
license=('GPL3')
depends=(
- 'zenity'
+ 'zenity'
'xdg-utils'
- 'zbar'
- 'qrencode'
- 'networkmanager'
+ 'zbar'
+ 'qrencode'
+ 'networkmanager'
)
options=('!emptydirs' '!strip')
source=("${pkgname}_${pkgver}-{pkgrel}_all.deb::https://github.com/kokoye2007/wifi-qr/releases/download/${pkgver}/${pkgname}_${pkgver}-${pkgrel}_all.deb")
@@ -20,5 +20,11 @@ sha256sums=('cc38985fe9cd4c44a550a2a6bc314bfc79b6b8d76e27b8da8e5de7beb403b08c')
package() {
cd "${pkgdir}"
+
+ # extract Debian data file
tar xf "${srcdir}/data.tar.xz"
+
+ # unpack Debian changelog file
+ gzip -d "usr/share/doc/wifi-qr/changelog.Debian.gz"
+ mv "usr/share/doc/wifi-qr/changelog.Debian" "usr/share/doc/wifi-qr/changelog"
}