summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfearlessgeekmedia2022-10-24 13:02:21 -0400
committerfearlessgeekmedia2022-10-24 13:02:21 -0400
commitd4238b5ff29b900dca2c13ecfe3a4e98ab527e94 (patch)
tree4eebea5127ed20b0e7fc89855de252aac6f80273
downloadaur-d4238b5ff29b900dca2c13ecfe3a4e98ab527e94.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..469769728cf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wifi4wofi-git
+ pkgdesc = bash script providing WiFi menu for wofi, forked from wofi-wifi-menu
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/fearlessgeekmedia/wifi4wofi
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = wofi
+ depends = networkmanager
+ depends = bash
+ depends = iw
+ depends = sed
+ depends = gawk
+ source = git+https://github.com/fearlessgeekmedia/wifi4wofi
+ sha256sums = SKIP
+
+pkgname = wifi4wofi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8fee8ed25d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michael Williams <fearlessgeekmedia@users.noreplay.github.com>
+# Contributor: Robin Opletal <fourstepper@users.noreply.github.com>
+# Contributor: Charlie Haley <charlie-haley@users.noreply.github.com>
+pkgname=wifi4wofi-git
+_pkgname=wifi4wofi
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="bash script providing WiFi menu for wofi, forked from wofi-wifi-menu"
+arch=("any")
+url="https://github.com/fearlessgeekmedia/wifi4wofi"
+license=("MIT")
+depends=("wofi" "networkmanager" "bash" "iw" "sed" "gawk")
+makedepends=('git')
+source=('git+https://github.com/fearlessgeekmedia/wifi4wofi')
+sha256sums=('SKIP')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -r "${srcdir}/wifi4wofi/wifi4wofi" "${pkgdir}/usr/bin/wifi4wofi"
+ chmod +x "${pkgdir}/usr/bin/wifi4wofi"
+ sudo cp -r "${srcdir}/wifi4wofi/config.example" "/usr/share/wofi/wifi.example"
+}