summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Sexton2023-11-23 12:16:18 -0500
committerMatthew Sexton2023-11-23 12:16:18 -0500
commitf97a27d6d2180cb9b7939d976eba4326ef17b1c2 (patch)
treeadda84f98421063c1ecf376eea59178facb93bb8
parent16a13a3ec77e08a9708d94a16b5a54a41e53b5c3 (diff)
downloadaur-wifite-git.tar.gz
Changed build method to setuptools
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0318b815648a..505680fa9c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = wifite-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
- pkgver = r679.71a2bf30a
- pkgrel = 1
+ pkgver = r729.dccebcdde
+ pkgrel = 2
url = https://github.com/kimocoder/wifite2
arch = any
license = GPL2
checkdepends = cowpatty
makedepends = git
- makedepends = python-build
- makedepends = python-installer
makedepends = python-pytest
makedepends = python-setuptools
- makedepends = python-wheel
+ makedepends = python-poetry
depends = python
depends = python-chardet
depends = aircrack-ng
diff --git a/PKGBUILD b/PKGBUILD
index 0577efc74dc5..40cfc4ca05b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: lsf <lsf@lsf>
pkgname=wifite-git
_pkgname=${pkgname%-git}
-pkgver=r679.71a2bf30a
-pkgrel=1
+pkgver=r729.dccebcdde
+pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/kimocoder/wifite2"
@@ -21,8 +21,10 @@ optdepends=(
'hcxdumptool: capturing PMKID hashes'
'hcxtools: converting PMKID packet captures into hashcat format'
)
-makedepends=('git' 'python-build' 'python-installer' 'python-pytest'
- 'python-setuptools' 'python-wheel')
+makedepends=( 'git'
+ 'python-pytest'
+ 'python-setuptools'
+ 'python-poetry')
checkdepends=('cowpatty')
source=(${pkgname}::git+${url}.git)
sha256sums=('SKIP')
@@ -42,12 +44,12 @@ prepare() {
build() {
cd "${pkgname}"
- python -m build --wheel --no-isolation
+ python setup.py build
}
package() {
cd "${pkgname}"
- python -m installer --destdir="${pkgdir}" dist/*.whl
+ python setup.py install --root="$pkgdir" --optimize=1
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}