summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorajs1242015-06-09 21:45:06 +0200
committerajs1242015-06-09 21:45:06 +0200
commitcfc146a6c29b0b2172f55c915e03cd0c8a374598 (patch)
tree051364ee83b9c8b1341bc897f8e97403684f4d99
downloadaur-cfc146a6c29b0b2172f55c915e03cd0c8a374598.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD29
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78fb203f0289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = wifite-git
+ pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
+ pkgver = 138.edbdedd
+ pkgrel = 1
+ url = https://github.com/derv82/wifite
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = aircrack-ng
+ depends = aircrack-ng-scripts
+ depends = python2-pexpect
+ optdepends = tk
+ optdepends = macchanger
+ optdepends = pyrit-svn
+ optdepends = cowpatty
+ optdepends = reaver
+ optdepends = wireshark-cli
+ conflicts = wifite
+ conflicts = wifite-svn
+ replaces = wifite
+ replaces = wifite-svn
+ source = wifite-git::git+https://github.com/derv82/wifite.git
+ sha256sums = SKIP
+
+pkgname = wifite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c577d0e8d3b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ajs124 < aur AT ajs124 DOT de >
+
+pkgname=wifite-git
+pkgver=138.edbdedd
+pkgrel=1
+pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
+arch=(any)
+url="https://github.com/derv82/wifite"
+license=('GPL')
+depends=(python2 aircrack-ng aircrack-ng-scripts python2-pexpect)
+optdepends=(tk macchanger pyrit-svn cowpatty reaver wireshark-cli)
+makedepends=(git)
+replaces=(wifite wifite-svn)
+conflicts=(wifite wifite-svn)
+source=($pkgname::git+https://github.com/derv82/wifite.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo `git rev-list --count master`.`git rev-parse --short master`
+}
+
+prepare() {
+ sed -i 's|^#!/usr/bin/python$|#!/usr/bin/python2|' $pkgname/wifite.py
+}
+
+package() {
+ install -D -m755 $pkgname/wifite.py ${pkgdir}/usr/bin/wifite
+}