summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevs-ch2017-08-30 12:03:11 +0200
committerevs-ch2017-08-30 12:03:11 +0200
commit1588ea4b0d1049c2e3f5b42abcd240b3831283a6 (patch)
treed04b4474fea5fd5e71c4653a574a77650edd0ff3
parent909c4df0951c01303d18db9c4865361fab1b77f7 (diff)
downloadaur-1588ea4b0d1049c2e3f5b42abcd240b3831283a6.tar.gz
pyshark as a hard dependency, tk not required
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50086ef5b50c..1d3874f12878 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = wifite2-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
pkgver = r104.aa75970
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/derv82/wifite2
arch = any
license = GPL
makedepends = git
depends = python2
depends = aircrack-ng
- optdepends = tk
+ depends = python2-pyshark
optdepends = macchanger
optdepends = pyrit-svn
optdepends = cowpatty
optdepends = reaver
- optdepends = python2-pyshark
source = wifite2-git::git+https://github.com/derv82/wifite2.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7d00d7d8840d..f1405d75271a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=wifite2-git
pkgver=r104.aa75970
-pkgrel=1
+pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/derv82/wifite2"
license=('GPL')
-depends=(python2 aircrack-ng)
-optdepends=(tk macchanger pyrit-svn cowpatty reaver python2-pyshark)
+depends=(python2 aircrack-ng python2-pyshark)
+optdepends=(macchanger pyrit-svn cowpatty reaver)
makedepends=(git)
source=($pkgname::git+https://github.com/derv82/wifite2.git)
sha256sums=('SKIP')
@@ -23,16 +23,16 @@ prepare() {
}
package() {
- mkdir -p ${pkgdir}/usr/bin
- mkdir -p ${pkgdir}/usr/share/wifite2
- install -D -m755 ${pkgname}/Wifite.py ${pkgdir}/usr/share/wifite2/Wifite.py
- cp -r $pkgname/py ${pkgdir}/usr/share/wifite2/py
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/wifite2
+ install -D -m755 ${pkgname}/Wifite.py ${pkgdir}/usr/share/wifite2/Wifite.py
+ cp -r $pkgname/py ${pkgdir}/usr/share/wifite2/py
- cat > "$pkgdir/usr/bin/wifite2" << EOF
+ cat > "$pkgdir/usr/bin/wifite2" << EOF
#!/bin/sh
# cd /usr/share/wifite2
exec python2 /usr/share/wifite2/Wifite.py "\${@}"
EOF
- chmod a+x "$pkgdir/usr/bin/wifite2"
+chmod a+x "$pkgdir/usr/bin/wifite2"
}