summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2022-08-12 11:20:37 +0200
committerlsf2022-08-12 11:20:37 +0200
commit1f3574a35437c6d4199e850516d75e5f15856dcd (patch)
tree6d62c84adc8e89d623951b1204b3c120c7835e5c
parentd1be4c8f595f65429e481f59b7f9b69bba616b44 (diff)
downloadaur-1f3574a35437c6d4199e850516d75e5f15856dcd.tar.gz
conflict with wifite; update deps a bit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD37
2 files changed, 43 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e0c8078c429..f5300025bad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,30 @@
pkgbase = wifite2-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
- pkgver = r492.29803917c
+ pkgver = r493.6fd209102
pkgrel = 2
url = https://github.com/kimocoder/wifite2
arch = any
- license = GPL
+ license = GPL2
makedepends = git
depends = python
depends = aircrack-ng
- depends = wireless_tools
+ depends = iw
+ depends = iproute2
depends = net-tools
- depends = wireshark-cli
depends = python-argparse
depends = python-chardet
- optdepends = macchanger
- optdepends = reaver
- optdepends = bully
- optdepends = cowpatty
- optdepends = pyrit
- optdepends = hcxdumptool
- optdepends = hcxtools
- optdepends = john
- optdepends = hashcat
+ optdepends = wireshark-cli: detecting WPS networks and inspecting handshake capture files
+ optdepends = reaver: WPS Pixie-Dust & brute-force attacks
+ optdepends = bully: WPS Pixie-Dust & brute-force attacks
+ optdepends = cowpatty: detect WPA handshakes
+ optdepends = pyrit: detect WPA handshakes
+ optdepends = macchanger: change MAC for attacks
+ optdepends = hashcat: cracking PMKID hashes
+ optdepends = john: cracking PMKID hashes
+ optdepends = hcxdumptool: capturing PMKID hashes
+ optdepends = hcxtools: converting PMKID packet captures into hashcat format
+ provides = wifite
+ conflicts = wifite
source = wifite2-git::git+https://github.com/kimocoder/wifite2.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1e8bf5ff8b68..abb2e05ba2e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,46 @@
# Maintainer : lsf <lsf@lsf>
pkgname=wifite2-git
-pkgver=r492.29803917c
+pkgver=r493.6fd209102
pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/kimocoder/wifite2"
-license=('GPL')
-depends=(python aircrack-ng wireless_tools net-tools
- wireshark-cli python-argparse python-chardet)
+license=('GPL2')
+depends=(python aircrack-ng iw iproute2 net-tools
+ python-argparse python-chardet)
# scapy: listed in requirements.txt, but not actually used atm
-optdepends=(macchanger reaver bully
- cowpatty pyrit hcxdumptool
- hcxtools john hashcat)
+optdepends=(
+ 'wireshark-cli: detecting WPS networks and inspecting handshake capture files'
+ 'reaver: WPS Pixie-Dust & brute-force attacks'
+ 'bully: WPS Pixie-Dust & brute-force attacks'
+ 'cowpatty: detect WPA handshakes'
+ 'pyrit: detect WPA handshakes'
+ 'macchanger: change MAC for attacks'
+ 'hashcat: cracking PMKID hashes'
+ 'john: cracking PMKID hashes'
+ 'hcxdumptool: capturing PMKID hashes'
+ 'hcxtools: converting PMKID packet captures into hashcat format' # should be part of hcxtools?
+)
+ # 'hcxpcapngtool: converting PMKID packet captures into hashcat format' # should be part of hcxtools?
makedepends=(git)
source=($pkgname::git+https://github.com/kimocoder/wifite2.git)
-
sha256sums=('SKIP')
+provides=('wifite')
+conflicts=('wifite')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build(){
+prepare() {
+ cd "$pkgname"
+ sed 's|sbin|bin|g' -i setup.cfg
+}
+
+
+build() {
cd "$pkgname"
python setup.py build
}
@@ -31,5 +48,5 @@ build(){
package() {
cd "$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- mv ${pkgdir}/usr/sbin ${pkgdir}/usr/bin
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}