summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2020-09-10 10:58:23 +0200
committerlsf2020-09-10 10:58:58 +0200
commit7cf264545161419c244e9e6c85b14094282ec452 (patch)
tree7dd626593fe7aebe6f37493b4681568bcd103788
parent871ac934aa59796a4d8511b6a2632fd77f979be3 (diff)
downloadaur-7cf264545161419c244e9e6c85b14094282ec452.tar.gz
wireshark_cli as a required dependency; python indentation fix
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--bad_indentation_fix.patch13
3 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ded3813d0c40..052b57a1ef36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wifite2-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
- pkgver = r358.327457a
- pkgrel = 1
+ pkgver = r376.5483a41
+ pkgrel = 2
url = https://github.com/kimocoder/wifite2
arch = any
license = GPL
@@ -10,8 +10,8 @@ pkgbase = wifite2-git
depends = aircrack-ng
depends = wireless_tools
depends = net-tools
+ depends = wireshark-cli
optdepends = macchanger
- optdepends = wireshark-cli
optdepends = reaver
optdepends = bully
optdepends = cowpatty
@@ -21,7 +21,9 @@ pkgbase = wifite2-git
optdepends = john
optdepends = hashcat
source = wifite2-git::git+https://github.com/kimocoder/wifite2.git
+ source = bad_indentation_fix.patch
sha256sums = SKIP
+ sha256sums = 79613c5d6fb8d4e2e09789a811a40de53b6a06a863802895ffe529f4e2f0e272
pkgname = wifite2-git
diff --git a/PKGBUILD b/PKGBUILD
index a457331ac012..281884bf5e40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer : lsf <lsf@lsf>
pkgname=wifite2-git
-pkgver=r358.327457a
-pkgrel=1
+pkgver=r376.5483a41
+pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/kimocoder/wifite2"
license=('GPL')
-depends=(python aircrack-ng wireless_tools net-tools)
-optdepends=(macchanger wireshark-cli reaver bully
+depends=(python aircrack-ng wireless_tools net-tools wireshark-cli)
+optdepends=(macchanger reaver bully
cowpatty pyrit hcxdumptool hcxtools john hashcat)
makedepends=(git)
-source=($pkgname::git+https://github.com/kimocoder/wifite2.git)
+source=($pkgname::git+https://github.com/kimocoder/wifite2.git
+ "bad_indentation_fix.patch")
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '79613c5d6fb8d4e2e09789a811a40de53b6a06a863802895ffe529f4e2f0e272')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i ../bad_indentation_fix.patch
+}
+
package() {
mkdir -p ${pkgdir}/usr/bin
mkdir -p ${pkgdir}/usr/share/wifite2
diff --git a/bad_indentation_fix.patch b/bad_indentation_fix.patch
new file mode 100644
index 000000000000..7c63a11e9bce
--- /dev/null
+++ b/bad_indentation_fix.patch
@@ -0,0 +1,13 @@
+diff --git a/wifite/tools/hashcat.py b/wifite/tools/hashcat.py
+index 967c308..7723937 100755
+--- a/wifite/tools/hashcat.py
++++ b/wifite/tools/hashcat.py
+@@ -50,7 +50,7 @@ class Hashcat(Dependency):
+ key = stdout.split(':', 5)[-1].strip()
+ break
+
+- if os.path.exists(hccapx_file) and hccapx_autoremove is True:
++ if os.path.exists(hccapx_file) and hccapx_autoremove is True:
+ os.remove(hccapx_file)
+
+ return key