summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevs-ch2017-08-30 11:55:23 +0200
committerevs-ch2017-08-30 11:55:23 +0200
commit909c4df0951c01303d18db9c4865361fab1b77f7 (patch)
tree24d75c448c4ea863ef9def46da2dd8d8c570f17f
downloadaur-909c4df0951c01303d18db9c4865361fab1b77f7.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50086ef5b50c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wifite2-git
+ pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
+ pkgver = r104.aa75970
+ pkgrel = 1
+ url = https://github.com/derv82/wifite2
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = aircrack-ng
+ optdepends = tk
+ optdepends = macchanger
+ optdepends = pyrit-svn
+ optdepends = cowpatty
+ optdepends = reaver
+ optdepends = python2-pyshark
+ source = wifite2-git::git+https://github.com/derv82/wifite2.git
+ sha256sums = SKIP
+
+pkgname = wifite2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d00d7d8840d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : Christian Hofmann <chof@pfho.net>
+
+pkgname=wifite2-git
+pkgver=r104.aa75970
+pkgrel=1
+pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
+arch=(any)
+url="https://github.com/derv82/wifite2"
+license=('GPL')
+depends=(python2 aircrack-ng)
+optdepends=(tk macchanger pyrit-svn cowpatty reaver python2-pyshark)
+makedepends=(git)
+source=($pkgname::git+https://github.com/derv82/wifite2.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ rm -rf $pkgname/py/tests
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/wifite2
+ install -D -m755 ${pkgname}/Wifite.py ${pkgdir}/usr/share/wifite2/Wifite.py
+ cp -r $pkgname/py ${pkgdir}/usr/share/wifite2/py
+
+ cat > "$pkgdir/usr/bin/wifite2" << EOF
+#!/bin/sh
+# cd /usr/share/wifite2
+exec python2 /usr/share/wifite2/Wifite.py "\${@}"
+EOF
+
+ chmod a+x "$pkgdir/usr/bin/wifite2"
+}