summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2022-08-11 11:29:51 +0200
committerlsf2022-08-11 11:29:51 +0200
commitd1be4c8f595f65429e481f59b7f9b69bba616b44 (patch)
tree7625624e8a9eaa1efff7730934461d60353a78bb
parentc27df2c6cd7211dbf2543cdbc9ca2435b427f5b1 (diff)
downloadaur-d1be4c8f595f65429e481f59b7f9b69bba616b44.tar.gz
switch to "normal" py setup installation
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e16c1b9ed71..7e0c8078c429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wifite2-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
- pkgver = r379.d8a6628
- pkgrel = 1
+ pkgver = r492.29803917c
+ pkgrel = 2
url = https://github.com/kimocoder/wifite2
arch = any
license = GPL
@@ -11,6 +11,8 @@ pkgbase = wifite2-git
depends = wireless_tools
depends = net-tools
depends = wireshark-cli
+ depends = python-argparse
+ depends = python-chardet
optdepends = macchanger
optdepends = reaver
optdepends = bully
@@ -24,4 +26,3 @@ pkgbase = wifite2-git
sha256sums = SKIP
pkgname = wifite2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 61eaad88cdb4..1e8bf5ff8b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer : lsf <lsf@lsf>
pkgname=wifite2-git
-pkgver=r379.d8a6628
-pkgrel=1
+pkgver=r492.29803917c
+pkgrel=2
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/kimocoder/wifite2"
license=('GPL')
-depends=(python aircrack-ng wireless_tools net-tools wireshark-cli)
+depends=(python aircrack-ng wireless_tools net-tools
+ wireshark-cli python-argparse python-chardet)
+ # scapy: listed in requirements.txt, but not actually used atm
optdepends=(macchanger reaver bully
- cowpatty pyrit hcxdumptool hcxtools john hashcat)
+ cowpatty pyrit hcxdumptool
+ hcxtools john hashcat)
makedepends=(git)
source=($pkgname::git+https://github.com/kimocoder/wifite2.git)
@@ -20,16 +23,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
- mkdir -p ${pkgdir}/usr/bin
- mkdir -p ${pkgdir}/usr/share/wifite2
- install -D -m755 ${pkgname}/Wifite.py ${pkgdir}/usr/share/wifite2/Wifite.py
- cp -r $pkgname/wifite ${pkgdir}/usr/share/wifite2/wifite
-
- cat > "$pkgdir/usr/bin/wifite2" << EOF
-#!/bin/sh
-exec python /usr/share/wifite2/Wifite.py "\${@}"
-EOF
+build(){
+ cd "$pkgname"
+ python setup.py build
+}
-chmod a+x "$pkgdir/usr/bin/wifite2"
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ mv ${pkgdir}/usr/sbin ${pkgdir}/usr/bin
}