summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris. H2018-10-05 17:24:57 +0200
committerChris. H2018-10-05 17:24:57 +0200
commite6cc41f064398bb3e872dcd9fe5a47eeea780582 (patch)
tree085a4286c35e3bb7e04cd3f5632b5948ccab5113
parentc9dfca6fa919d179a93653c3745ef811eef61c97 (diff)
downloadaur-e6cc41f064398bb3e872dcd9fe5a47eeea780582.tar.gz
update/fix dependencies, switch to python3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD8
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 047c3cb36b6f..d131864df3f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,24 @@
pkgbase = wifite2-git
pkgdesc = A tool to attack multiple WEP and WPA encrypted networks at the same time
- pkgver = r190.90c99b1
+ pkgver = r279.e190794
pkgrel = 1
url = https://github.com/derv82/wifite2
arch = any
license = GPL
makedepends = git
- depends = python2
+ depends = python
depends = aircrack-ng
- depends = python2-pyshark
- depends = pyrit
- depends = cowpatty
- depends = reaver
- depends = scapy
+ depends = wireless_tools
+ depends = net-tools
optdepends = macchanger
+ optdepends = wireshark-cli
+ optdepends = reaver
+ optdepends = bully
+ optdepends = cowpatty
+ optdepends = pyrit
+ optdepends = hcxdumptool
+ optdepends = hcxtools
+ optdepends = john
source = wifite2-git::git+https://github.com/derv82/wifite2.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 98f3dc7b22d6..e8cd3eec2420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer : Christian Hofmann <chof@pfho.net>
pkgname=wifite2-git
-pkgver=r190.90c99b1
+pkgver=r279.e190794
pkgrel=1
pkgdesc="A tool to attack multiple WEP and WPA encrypted networks at the same time"
arch=(any)
url="https://github.com/derv82/wifite2"
license=('GPL')
-depends=(python2 aircrack-ng python2-pyshark pyrit cowpatty reaver scapy)
-optdepends=(macchanger)
+depends=(python aircrack-ng wireless_tools net-tools)
+optdepends=(macchanger wireshark-cli reaver bully cowpatty pyrit hcxdumptool hcxtools john)
makedepends=(git)
source=($pkgname::git+https://github.com/derv82/wifite2.git)
sha256sums=('SKIP')
@@ -26,7 +26,7 @@ package() {
cat > "$pkgdir/usr/bin/wifite2" << EOF
#!/bin/sh
-exec python2 /usr/share/wifite2/Wifite.py "\${@}"
+exec python /usr/share/wifite2/Wifite.py "\${@}"
EOF
chmod a+x "$pkgdir/usr/bin/wifite2"