summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2017-01-08 13:19:28 +0100
committerChristian Krause2017-01-08 13:19:28 +0100
commitb63791b6267fb6c922aa408e83f14559d2cbb5fc (patch)
tree8b351809cebdf95ded6ebac28b02b0161f59d893
parent993b2b5c5b5c791ff896db54f5363ea9cb35209b (diff)
downloadaur-b63791b6267fb6c922aa408e83f14559d2cbb5fc.tar.gz
wiggletools-1.2.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 10 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc5793151769..6f0e83a8d43f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 8 12:19:20 UTC 2017
pkgbase = wiggletools
pkgdesc = basic operations on the space of numerical functions defined on the genome using lazy evaluators for flexibility and efficiency
- pkgver = 1.1
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/Ensembl/WiggleTools
arch = i686
arch = x86_64
license = Apache
- makedepends = git
- makedepends = libmariadbclient
- makedepends = libpng
- makedepends = unzip
depends = gsl
+ depends = htslib
+ depends = libbigwig
depends = python2
- source = wiggletools-1.1.tar.gz::https://github.com/Ensembl/WiggleTools/archive/v1.1.tar.gz
- md5sums = 7b7052b755415936324d7919756bd070
+ source = wiggletools-1.2.1.tar.gz::https://github.com/Ensembl/WiggleTools/archive/v1.2.1.tar.gz
+ md5sums = 516a63ee41dcf63104a0664735e75cee
pkgname = wiggletools
diff --git a/PKGBUILD b/PKGBUILD
index fe935a0de070..5703b48a2d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,19 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=wiggletools
-pkgver=1.1
+pkgver=1.2.1
pkgrel=1
pkgdesc="basic operations on the space of numerical functions defined on the genome using lazy evaluators for flexibility and efficiency"
arch=('i686' 'x86_64')
url="https://github.com/Ensembl/WiggleTools"
license=('Apache')
-depends=('gsl' 'python2')
-makedepends=('git' 'libmariadbclient' 'libpng' 'unzip')
+depends=('gsl' 'htslib' 'libbigwig' 'python2')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Ensembl/WiggleTools/archive/v$pkgver.tar.gz")
-md5sums=('7b7052b755415936324d7919756bd070')
+md5sums=('516a63ee41dcf63104a0664735e75cee')
prepare() {
cd $srcdir/WiggleTools-$pkgver
- git archive --format=zip -9 --remote=git://genome-source.cse.ucsc.edu/kent.git beta src/userApps > userApps.zip
- unzip -o -d userApps -j userApps.zip
- rm userApps.zip
-
- sed -e 's|-ltinfo||g' \
- -i samtools/Makefile
-
- # use python2
- sed -e 's|python test.py|python2 test.py|' \
- -i Makefile
-
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
-i python/wiggletools/*.py
}
@@ -33,14 +21,6 @@ prepare() {
build() {
cd $srcdir/WiggleTools-$pkgver
- pushd userApps
- make fetchSource
- make
- popd
-
- export KENT_SRC=$PWD/userApps/kent/src
- export TABIX_SRC=$PWD/userApps/samtabix
-
make
}
@@ -59,8 +39,6 @@ package() {
install -Dm755 $pythonscript $pkgdir/usr/bin/$(basename $pythonscript .py)
done
- rm $pkgdir/usr/bin/__init__
-
for shellscript in bin/*.sh ; do
install -Dm755 $shellscript $pkgdir/usr/bin/$(basename $shellscript .sh)
done