summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:56:46 +0200
committerLubosz Sarnecki2015-06-22 22:56:46 +0200
commitb71197624c78c798c706f3b2a04c24800371926b (patch)
tree81ec2372dd2e637b3331d0df0033cee83e604ef1
downloadaur-wiic-svn.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--usleep.patch12
4 files changed, 88 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8de3ae2aee79
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = wiic-svn
+ pkgdesc = WiiC is a C/C++ library that manages Wii devices. It supports Wiimote, Nunchuck, Classic, Guitar Hero 3, Motion Plus, and Balance Board.
+ pkgver = 90
+ pkgrel = 2
+ url = http://sourceforge.net/projects/wiic/
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = svn
+ depends = bluez
+ depends = opencv
+ provides = wiic
+ conflicts = wiic
+ source = wiic::svn+https://wiic.svn.sourceforge.net/svnroot/wiic/src/
+ source = usleep.patch
+
+pkgname = wiic-svn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..523278f48832
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wiic-svn
+ pkgdesc = WiiC is a C/C++ library that manages Wii devices. It supports Wiimote, Nunchuck, Classic, Guitar Hero 3, Motion Plus, and Balance Board.
+ pkgver = 90
+ pkgrel = 2
+ url = http://sourceforge.net/projects/wiic/
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = svn
+ depends = bluez
+ depends = opencv
+ provides = wiic
+ conflicts = wiic
+ source = wiic::svn+https://wiic.svn.sourceforge.net/svnroot/wiic/src/
+ source = usleep.patch
+ sha256sums = SKIP
+ sha256sums = b025fd075b63f8d5cc6f3903d700f3fecd26ab317626b06749181488a16d1695
+
+pkgname = wiic-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..463ea44dd182
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+_realname=wiic
+pkgname=$_realname-svn
+pkgver=90
+pkgrel=2
+pkgdesc="WiiC is a C/C++ library that manages Wii devices. It supports Wiimote, Nunchuck, Classic, Guitar Hero 3, Motion Plus, and Balance Board."
+arch=('any')
+url="http://sourceforge.net/projects/wiic/"
+license=('GPL3')
+conflicts=('wiic')
+provides=('wiic')
+depends=('bluez' 'opencv')
+makedepends=('cmake' 'svn')
+
+source=( "wiic::svn+https://wiic.svn.sourceforge.net/svnroot/wiic/src/"
+ "usleep.patch")
+sha256sums=( 'SKIP'
+ 'b025fd075b63f8d5cc6f3903d700f3fecd26ab317626b06749181488a16d1695')
+
+pkgver() {
+ cd $_realname
+ svnversion | tr -d [A-z]
+}
+
+build() {
+ cd $_realname
+ patch -p0 < ../../usleep.patch
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd $_realname
+ make DESTDIR=$pkgdir install
+ mv $pkgdir/usr/local/* $pkgdir/usr
+ rm $pkgdir/usr/local/ -R
+}
diff --git a/usleep.patch b/usleep.patch
new file mode 100644
index 000000000000..e53d2b6abde3
--- /dev/null
+++ b/usleep.patch
@@ -0,0 +1,12 @@
+Index: wiicpp/wiicpp.h
+===================================================================
+--- wiicpp/wiicpp.h (revision 90)
++++ wiicpp/wiicpp.h (working copy)
+@@ -33,6 +33,7 @@
+ #ifndef WIICPP_H_
+ #define WIICPP_H_
+
++#include <unistd.h>
+ #include <vector>
+ #include <wiic.h>
+ #include <dataset.h>