summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-12 12:59:39 -0600
committerMark Wagie2021-04-12 12:59:39 -0600
commitcf7354ce102697b17d3053b35e6d3fcb0753d13e (patch)
tree2e1ba30601fea0c2e93e1e7e135ad2b8ac69d1cc
downloadaur-cf7354ce102697b17d3053b35e6d3fcb0753d13e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD26
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c586e4706ab2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wike
+ pkgdesc = Wikipedia Reader for the GNOME Desktop
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/hugolabe/Wike
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ depends = gtk3
+ depends = python-gobject
+ depends = python-requests
+ depends = webkit2gtk
+ source = wike-1.1.0.tar.gz::https://github.com/hugolabe/Wike/archive/refs/tags/1.1.0.tar.gz
+ sha256sums = 937b67d3b90b6442f1e9081a17f92bf12bc9a32ee6553efdf3f8528a5ea570b0
+
+pkgname = wike
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc98c4349e0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=wike
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Wikipedia Reader for the GNOME Desktop"
+arch=('x86_64')
+url="https://github.com/hugolabe/Wike"
+license=('GPL3')
+depends=('gtk3' 'python-gobject' 'python-requests' 'webkit2gtk')
+makedepends=('meson')
+#checkdepends=('appstream-glib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('937b67d3b90b6442f1e9081a17f92bf12bc9a32ee6553efdf3f8528a5ea570b0')
+
+build() {
+ arch-meson Wike-$pkgver build
+ meson compile -C build
+}
+
+#check() {
+# meson test -C build
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}